Welcome! Log In Create A New Profile


[Synology][DS411slim] Another brick in the wall ?

Posted by P'titLu 
[Synology][DS411slim] Another brick in the wall ?
March 21, 2021 04:13PM
I have a DS411slim with a blicking blue light.
The first symptoms were that the NAS would become unresponsive. At first it happened after a few weeks of normale activity. A reboot would then fix it after unpluging the Synology. It then happened more and more, till the DS411slim won't boot anymore, stuck in blicking blue light of death.
Gladly, by using a Raspberry Pi, I was able to regain access my data without loosing anything.

I went through usual tests : removed each disk, one at a time, removed all disks, tried a hard reset, and visually check the motherboard.
I haven't see any damaged component on the mother board, but those are so fin that it is not easy to say.
I've check the power supply, it seems to deliver 12v, even during boot. But my multimeter is not really accurate.

No clue...

Googling around, I found here many relevant information and decided to go a bit further.
I then get a rs232 module and consoled to the DS411slim, getting inspiration from https://forum.doozan.com/read.php?3,100059 for exemple.

My first attempt showed encouraging things :

| \/ | __ _ _ ____ _____| | |
| |\/| |/ _` | '__\ \ / / _ \ | |
| | | | (_| | | \ V / __/ | |
|_| |_|\__,_|_| \_/ \___|_|_|
_ _ ____ _
| | | | | __ ) ___ ___ | |_
| | | |___| _ \ / _ \ / _ \| __|
| |_| |___| |_) | (_) | (_) | |_
\___/ |____/ \___/ \___/ \__| ** LOADER **
** MARVELL BOARD: Synology Disk Station LE
U-Boot 1.1.4 (Aug 9 2010 - 19:58:12) Marvell version: 3.5.3
CPU : Marvell Feroceon (Rev 1)
So far so good...

It then went to :
Uncompressing Linux... done, booting the kernel.
And .. stayed stucked :-(

OK, fine, it looks a lot at things I have seen when Googling, so I found an appropriate .pat file, extracted the zlimage file and tftp it to the Synology.
Trying a bootm, the console goes a bit further, begin booting the kernel and... stalled.

I tried another time, and the startup procedure went a bit further and stalled again.
The third try stalled too, but at another point.
Surprising... :-/

I tried again the normal startup, with the same constatation : the boot sequence would start but stalled at some point, never the same.
After numerous tries, the console showed the login demand. Wow !

Unfortunatly, I have forgotten my login and password. So I decided to add 2 new disks and try a fresh install.
Rebooting went fine and the Synology Assistant found my NAS.
I gave it the information it needs to install and it started fine, but ... stalled... :-(

And again...
And again...

So basically, my DS411slim is stalling in the boot sequence or after.
  • When it is in the boot sequence, it leads to the famous blinking blue light.
  • When it stall after booting, the NAS just becomes unresponsive.

What do you think ?
Any hint ?

Re: [Synology][DS411slim] Another brick in the wall ?
March 21, 2021 04:45PM

I don't know much about Synology stock FW, so cannot help you with this problem.

However, the DS411slim is already supported in mainline. So you can install my released Debian and Linux kernel (on USB first, and then later move it to the HDD, if you like to).

If you want to run Debian and forget about stock, I can help you.

Forum Wiki
bodhi's corner (buy bodhi a beer)

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.