Welcome! Log In Create A New Profile

Advanced

2017.07 U-Boot Kirkwood - GoFlexNet, GoFlexHome, PogoE02, Dockstar, iConnect, NetgearStora, PogoV4/Mobile, Sheevaplug, NSA325, NSA320, NSA310S, NSA320S, NSA310, HP T5325, Dreamplug

Posted by bodhi 
@lll
I don't understand what you are taking about. what tool?.

The 3TB issue was with the NTFS driver and I have installed ntfs-3g to fix the issue. I am not an arch-user. I know I can make a hybrid MBR, but my 3TB was already filled with 80% of data, so re sizing the partition is not an good idea with 80% of data.



Edited 1 time(s). Last edit at 07/25/2014 01:56PM by vaidyasr.
Quote
III
why in the hell you need arch with that machinegun-like question fire rate?
I've always thought of arch-users as of doers not talkers.
I mean if you don't know how to use the tool, maybe you shouldn't? )

LOL.

@vaidyasr, I'm banning you from this thread :)) Kidding aside, again, pls post in a new thread for questions that are not related to this U-Boot.

-bodhi
===========================
Forum Wiki
bodhi's corner
@bodhi : Does your uBoot for PogoV4 support booting from SATA?
@varkey,

Yes it does! bootcmd is set up to boot USB, SD, SATA in that order. So if you plug in only SATA it will boot SATA.

-bodhi
===========================
Forum Wiki
bodhi's corner
Quote
bodhi
@varkey,

Yes it does! bootcmd is set up to boot USB, SD, SATA in that order. So if you plug in only SATA it will boot SATA.

-bodhi

Perfect! :) Great work.
All,

I'm looking for download the link to davygravy's NSA320 u-boot image. Please post if you have that download link.
Thanks!

-bodhi
===========================
Forum Wiki
bodhi's corner
https://dl.dropboxusercontent.com/u/1015928/Kirkwood/rootfs_images/NSA320quickstart.tar.gz


"uboot.NAND-NSA320-IDEfixedv4-scripted.kwb" is in there

Hope this helps :)



Edited 1 time(s). Last edit at 08/04/2014 10:54PM by fsm.
fsm,

Thanks! I saw that but was not sure if it is the last one davygravy has. I'm trying to boot the NSA325 with UART, so far unsuccesffuly, so just trying get as many different U-Boot versions as I can get my hands on.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 08/05/2014 12:03AM by bodhi.
i have followed the steps in this thread and updated the uboot of my pogov4.

now when i try to boot my freshly made rootfs usb disk as described i do not get an ip it seems, at least i can not connect to it in any way.

it seems to boot normal, after some blinking i get a steady green light. anyting else i can do?


edit:

ok so i soldered some wires on the board and debian boots fine, just there is no network connection set up

during boot i do see: "Warning: failed to set MAC address"

what i did was #printenv, and indeed ethaddr was not set

so

# setenv 'xx:xx:xx:xx:xx:xx'
and after this

#saveenv

did the trick for me

its happely booting from the SDcard :D



Edited 1 time(s). Last edit at 08/07/2014 10:18AM by Tripleflix.
Great job getting it working!

My favorite part was:
ok so i soldered some wires on the board and debian boots fine,
fsm Wrote:
-------------------------------------------------------
> Great job getting it working!
>
> My favorite part was:
> ok so i soldered some wires on the board and
> debian boots fine,
>

i think it has litteraly been like 10 years since i last used a soldering iron, but some things you simple know once you learned it... seting up a serial connection wasnt so hard either, just remember to correctly wire the Tx and Rx, cus i got them mixed and didnt get an output at first :P
Hi,
Updated my uboot and uboot env to the newest listed on the first page. I have a v4 and had not had any issues until I updated the env.
I missed a few steps at the bottom in part 2, namely updating the mtdparts and rootfstype. So of course after rebooting, no boot. I didn't panic though.
I built a rescue usb and booted and was able to correct the mtdparts env and rootfstype. Everything worked good for a single USB drive boot after that except netconsole. It would not pick it up. I had changed the severip and ipaddr variable, but I cannot get the netconsole to pick up. Is the port different than 6666 for this uboot env?
Also, with 2 other hard drives attached, I don't think the device is booting right. I can't find it in my network. I know there was a setting for the last env that would boot by label but I haven't seen that for this. Hoping there is an easy solution, as I'd like to be on the newer version.
Thanks!
t3ch42,

I realized now I should have mentioned netconsole in the instruction.

For netconsole, set the preboot variable with fw_setenv. The default settings has only preboot_nc (since I don't want to assume that users want to activate netconsole by default).
preboot_nc=run if_netconsole start_netconsole
preboot=run preboot_nc

To help the kernel to find the correct rootfs, use rootfs partition label:
http://forum.doozan.com/read.php?3,8044,8152#msg-8152

-bodhi
===========================
Forum Wiki
bodhi's corner
Whew.
Glad that was easy.
Will give it a try this evening. Its hard to stay on top of all aspects with all of the electronics I use; sometimes it seems I have just enough to get by.
Thanks for the quick reply.
I have bad blocks:
Pogoplug V1
dmesg | grep -i 'bad'
[   19.766086] Scanning device for bad blocks
[   19.838307] Bad eraseblock 637 at 0x000004fa0000
[   20.158075] Bad eraseblock 3589 at 0x00001c0a0000

and on my Pogoplug V4
dmesg | grep -i 'bad'
[    1.897690] Scanning device for bad blocks
[    2.014965] Bad eraseblock 1006 at 0x000007dc0000

Any way to fix this?

Edit:
Also my Pogoplug V3 has bad blocks:
[    1.423938] Scanning device for bad blocks
[    1.455326] Bad eraseblock 334 at 0x0000029c0000

WTF?



Edited 2 time(s). Last edit at 08/13/2014 11:51AM by theliquid.
@theliquid,

Nothing to be concerned. From now on, if you get more bad blocks then yes, keep watch on them. And your bad blocks are in the stock FW (kernel/rootfs) area so they do not affect u-boot (1st 1M). Only later if you want to flash your kernel and/or rootfs to NAND then they will have be accounted for.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 08/13/2014 03:02PM by bodhi.
Hi,

Is there anyway to get the kernel boot process to show on netconsole? I get the u-boot info and then


Starting kernel ...

But then there is no more output on the netconsole. Is it possible to get the rest of the output or do we lose it since the ip address changes once it boots.
See this thread:
http://forum.doozan.com/read.php?2,9522

-bodhi
===========================
Forum Wiki
bodhi's corner
bodhi Wrote:
-------------------------------------------------------
> @theliquid,
>
> Nothing to be concerned. From now on, if you get
> more bad blocks then yes, keep watch on them. And
> your bad blocks are in the stock FW
> (kernel/rootfs) area so they do not affect u-boot
> (1st 1M). Only later if you want to flash your
> kernel and/or rootfs to NAND then they will have
> be accounted for.
OK, thanks! I haven't noticed these bad blocks before, so I was very surprised... Anyway I'll try to update the Uboot in the next few days and report back.
Update: my 2 devices with bad blocks worked fine.

My other PogoV4 has also got a bad block:

root@debian:~# dmesg | grep Bad
[    5.131787] Bad eraseblock 80 at 0x000000a00000

Is it safe to flash too?

Edit: nvm, I figured it out myself. It was safe to flash, because the bad block is at 10M :)



Edited 1 time(s). Last edit at 08/15/2014 06:27PM by theliquid.
I have a dockstar to which i would like to flash the latest uboot (2014.07). I do have a bad block as shown here;
root@ds_167:/tmp# dmesg | grep -i 'bad'
[   16.227821] Scanning device for bad blocks
[   16.366403] Bad eraseblock 1806 at 0x00000e1c0000
Can I go forward with flashing?

Thanks

EDIT Never mind, figured it out myself and did a successful flash

DockStar> version
 v e r s i o n 

U-Boot 2014.07-tld-1 (Jul 18 2014 - 00:47:44)
Seagate FreeAgent DockStar
gcc (Debian 4.6.3-14) 4.6.3
GNU ld (GNU Binutils for Debian) 2.22
DockStar>

Thanks



Edited 1 time(s). Last edit at 08/16/2014 08:54AM by laprjns.
FYI.

1st post was updated:

Quote

References:

U-Boot source code at GitHub (Latest branch 2014.07.b-kirkwood, tag v2014.07-kirkwood)

-bodhi
===========================
Forum Wiki
bodhi's corner
gaogao & other NSA320 users,

In reference to this NSA320 test U-Boot in this post:
http://forum.doozan.com/read.php?3,12381,16787#msg-16787

If you have problem connecting UART, please try both
./kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2013.10-tld-0.1.nsa320.mtd0.kwb
and
./kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2013.10-tld-0.1.nsa320.mtd0.kwb -p

And watch the power button, when pressed does it flicker (temporarily off and on) once?

-bodhi
===========================
Forum Wiki
bodhi's corner
WIll this u-boot work in NSA 310?
PawelW Wrote:
-------------------------------------------------------
> WIll this u-boot work in NSA 310?

It might or might not. Each U-Boot needs to be built for that machine (different memory, frequency, …). The 310 and 320 are cousins so it might.

I did not build U-Boot for the NSA310, becaus I never got feeback on the Kirkwood kernel and rootfs, so I thought there is no one interests in the NSA310.

-bodhi
===========================
Forum Wiki
bodhi's corner
tks bodhi for the tip, "-p" made it work:

 99 % [....................................]
[Type Ctrl-\ + c to quit]


U-Boot 2013.10-tld-0.1 (Jul 24 2014 - 15:03:15)
ZyXEL NSA320 2-Bay Power Media Server

SoC:   Kirkwood 88F6281_A1
DRAM:  512 MiB
WARNING: Caches not enabled
NAND:  128 MiB
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   egiga0
Warning: failed to set MAC address

MV88E1318 PHY initialized on egiga0
NSA320> printenv
baudrate=115200
bootdelay=3
ethact=egiga0
stderr=serial
stdin=serial
stdout=serial

Environment size: 96/131068 bytes

However, as you see there is no environment set, and I still can't access the ide disk:

NSA320> ide reset

Reset IDE: Bus 0: ...........OK Bus 1: not available  
  Device 0: Model: ST4000DM000-1F2168 Firm: CC52 Ser#: W300FJ5X
            Type: Hard Disk
            Supports 48-bit addressing
            Capacity: 3815447.8 MB = 3726.0 GB (7814037168 x 512)
NSA320> ext2ls ide 0:1 / 
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **
NSA320> ext4ls ide 0:2 /
Failed to mount ext2 filesystem...
** Unrecognized filesystem type **

the disk is partitioned this way:

gaogao@mynas:~$ sudo parted /dev/sda
GNU Parted 2.3
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) p                                                                
Model: ATA ST4000DM000-1F21 (scsi)
Disk /dev/sda: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End     Size    File system  Name     Flags
 1      17.4kB  4000MB  4000MB  ext2         primary
 2      4000MB  3996GB  3992GB  ext4         primary


Reading the usb flash I use to boot the NSA works:

NSA320> usb reset
(Re)start USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
NSA320> ext2ls usb 0:1 /boot
<DIR>       4096 .
<DIR>       4096 ..
         2399792 uImage
         2399728 vmlinuz-3.13.1-kirkwood-tld-2
         1698808 System.map-3.13.1-kirkwood-tld-2
         6750476 uInitrd
          121807 config-3.13.1-kirkwood-tld-2
         6750412 initrd.img-3.13.1-kirkwood-tld-2
         2191504 uImage-3.10.4-kirkwood-tld-1
         2221032 uImage-3.12.0-kirkwood-tld-5
         6482584 uInitrd-3.12.0-kirkwood-tld-5
         1660174 System.map-3.12.0-kirkwood-tld-5
         2342512 vmlinuz-3.12.0-kirkwood-tld-5
          120273 config-3.12.0-kirkwood-tld-5
         6726514 initrd.img-3.12.0-kirkwood-tld-5

update: I manually recreated the environment and managed to boot from my usb boot disk, all good!



Edited 2 time(s). Last edit at 08/21/2014 12:02PM by gaogao.
Thanks Gaogao!

Yes, the EFI/GPT option is missing in this NSA320 U-boot build. I will upload another version.

-bodhi
===========================
Forum Wiki
bodhi's corner
Tks! Can't wait :)

Have you noticed the misleading message given by ext4ls?

NSA320> ext4ls ide 0:2 /
Failed to mount ext2 filesystem...
@gaogao and others NSA320 users,

Here is the latest U-Boot-2013.10 NSA320 for testing. Please test with UART if you have serial console, but do not flash to NAND yet until we have testers confirmation!

Boot with UART:
./kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2013.10-tld-1.nsa320.mtd0.kwb -p
Note that you will see CRC error in environment. This is because the envs location this U-Boot uses is 0xC0000. There is nothing in that location yet. Feel free to set the envs to boot into Debian just like you have done before, but don't save with saveenv. Just cut/paste the old envs to set them here for booting.

Download at Dropbox:
uboot.2013.10-tld-1.nsa320.bodhi.tar
md5
65a90081b69c294e88d5740f277b6736

This is the same download link in this previous post: http://forum.doozan.com/read.php?3,12381,16787#msg-16787).

-bodhi
===========================
Forum Wiki
bodhi's corner
Brilliant!
Not only it reads the disk partitions properly, but also the current uboot environment; as a result it booted directly to my previously populated HDD partition :)

I assume it's then safe to flash it, pls confirm.
Sorry, you can't reply to this topic. It has been closed.