Welcome! Log In Create A New Profile


uboot install corrupted, fw_printenv "permission denied"

Posted by cadre 
uboot install corrupted, fw_printenv "permission denied"
August 17, 2013 11:07AM
I've got a problem, I can't run fw_printenv without getting "permission denied"

I tried to install Jeff's uboot script last night on a brand new POGO-E02 but midway through the script my internet connection dropped and stayed out for over 5 minutes. When the internet feed came back up the script would not recover so I was forced to issue a Ctrl+C and stopped the script.

The components partially installed, but obviously the fw_printenv hosed up.

I attempted to re-run the script and it completes but the fw_printenv is unchanged and when I try to run it I get a "permission denied" error.

I believe this may be a simple fix. I do have good working POGO-E02 (uboot installed fine) as well hoping that would help in the solution, but so far I haven't been able to figure it out.

I tried to WinSCP / Putty to it to change permissions, but it's a read-only file system.

If anyone has any idea on how to get around this, any help would be greatly appreciated.
open | download - uboot install problem.JPG (75.6 KB)
Re: uboot install corrupted, fw_printenv "permission denied"
August 17, 2013 03:50PM
Alright, I did manage to fix this problem. I simply remounted the /dev/root mount as read write.

mount -o remount,rw /dev/root

dowloaded the fw_printenv file from jeff's mirror website. changed it's permissions to 755 and overwrote the old version to the /usr/sbin folder

then changed the mount back to read only

mount -o remount,ro /dev/root

I've rebooted the system and can now execute fw_printenv fine now as well as surviving after a cold boot.

Hopefully everything else will work as expected later too.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.