Welcome! Log In Create A New Profile


Booting Debian on Pogoplug Pro

Posted by bodhi 
Re: Booting Debian on Pogoplug Pro
September 22, 2012 04:48PM
bharath Wrote:
> If you have a working rootfs on the USB drive you
> can use that as the rootfs for the SATA drive as
> well. I am not sure what the current status of 3.x
> kernel is for oxnas that warheadsse was working
> on.

Yeah, I know it should be the same. But it's irrelevant to what I was thinking :-) The point is to be able to replace uImage with one built from the 3.x.x tree on a Debian rootfs. Using WarheadsSE setup to boot soley from SATA, the uImage is on the SATA drive, not in NAND, so it is very easy to deal with.
Re: Booting Debian on Pogoplug Pro
September 22, 2012 04:51PM
I tried the updated ALARM kernel with debian, unfortunately the instant the network comes up I have an oops. Does one require libaccept4 to use the newer kernel?
Re: Booting Debian on Pogoplug Pro
September 22, 2012 04:59PM
If you use Varkey's rootfs then most likely you will need to look at the modules under /lib/modules/ and replace them with newer version from the ALARM stick. Or you can just download the latest OXNAS rootfs and extract the files.
Re: Booting Debian on Pogoplug Pro
September 22, 2012 05:18PM
I replaced /lib/modules/ with the newer modules. The old kernel and old modules boot file, but when I try the newer kernel with newer modules I have an oops once the network is up.
Re: Booting Debian on Pogoplug Pro
September 22, 2012 06:04PM
Do you have serial console hooked up to see what is the oops look like?
Re: Booting Debian on Pogoplug Pro
September 22, 2012 07:16PM
Re: Booting Debian on Pogoplug Pro
September 22, 2012 11:38PM
I had to revert back to ALARM as pogo it serves my media. I will try to switch it back to debian and get the oops.
Re: Booting Debian on Pogoplug Pro
September 23, 2012 09:21AM
I figured out the issue. The problem being that varkey's rootfs actually has all the kernel modules uncompressed. This causes it to load the older kernel modules in some instances causing everything to break.
Re: Booting Debian on Pogoplug Pro
October 04, 2012 09:31PM
I installed ArcLinux Arm on my pogoplug P21, which share the same install package as Pro. I put Varkey's rootfs on a stick after ArcLinux ran ok on my P21, and then power it off -> plugin the stick with Varkey's rootfs -> power on. I got a similar Oops on network (eth0) with network cable plugged. If I unplug the network cable, it can boot without problem. Of course, in that case, eth0 is down (network is disabled). I tried following the thread to copy the related modules from ArcLinux stick to Varkey's stick but the new ArcLinux rootfs got changed. There is NO file under its /lib/modules. Where can I find the new modules on ArcLinux rootfs? Alternatively, if any of you can upload your working ArcLinux rootfs for me, I'd really appreciate! I have been struggling for this for several days...

Here's the log about the problem I captured via serial cable. The "Oops" is after this line "ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready ". It happened when it booted or when network cable's plugged in.

Setting Linux mem= boot arg value
Hit any key to stop autoboot: 0

Loading from device 0: 128MiB 3,3V 8-bit (offset 0x500000)
-- Using 1bit ECC style encoding
Image Name: Linux-
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2288744 Bytes = 2.2 MB
Load Address: 60008000
Entry Point: 60008000
## Booting image at 60500000 ...
Image Name: Linux-
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2288744 Bytes = 2.2 MB
Load Address: 60008000
Entry Point: 60008000
Verifying Checksum ... OK

Starting kernel ...

Uncompressing Linux.............................................................
............................................................................. do
ne, booting the kernel.
[ 0.000000] Linux version (root@hunchback) (gcc version 4.7.
0 20120505 (prerelease) (GCC) ) #6 SMP Thu Jun 14 19:49:57 CDT 2012
[ 0.000000] CPU: ARMv6-compatible processor [410fb025] revision 5 (ARMv7), cr
[ 0.000000] CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction c
(skipped to save space)

Activating lvm and md swap...done.
Checking file systems...fsck from util-linux-ng 2.17.2
Mounting local filesystems...done.
Activating swapfile swap...done.
Cleaning up temporary files....
Configuring network interfaces...[ 21.040000] eth0: PHY is Realtek RTL8211D, t
ype 0x001cc914
[ 21.040000] CoPro offload is active on eth0
[ 21.050000] Alloc'ing ARM descs 8192 bytes
[ 21.050000] Alloc'ing CoPro parameters 36 bytes
[ 21.050000] gmac gmac.0: firmware: requesting gmac_copro_firmware
[ 21.090000] CoPro: Programming start address as 0xd000e000
[ 21.190000] eth0: Resetting GMAC
[ 21.190000] eth0: GMAC reset complete
[ 21.200000] eth0: Setting Rx flow control thresholds for LAN port
[ 21.760000] eth0: PHY is Realtek RTL8211D, type 0x001cc914
[ 22.260000] eth0: link down
[ 24.240000] ADDRCONF(NETDEV_UP): eth0: link is not ready
Cleaning up temporary files....
Setting kernel variables ...done.
INIT: Entering runlevel: 2
Using makefile-style concurrent boot in runlevel 2.
Starting enhanced syslogd: rsyslogd[ 25.760000] eth0: link up, 1000Mbps, full-
duplex, using pause, lpa 0xCDE1
[ 25.760000] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 25.790000] Linearizing skb with frag_list
[ 25.790000] Bad mode in data abort handler detected
[ 25.790000] Unable to handle kernel NULL pointer dereference at virtual addre
ss 00000000
[ 25.790000] pgd = c0004000
[ 25.790000] [00000000] *pgd=00000000
[ 25.790000] Internal error: Oops: 805 [#1] SMP
[ 25.790000] Modules linked in: bootled_module gmac mii
[ 25.790000] CPU: 0 Not tainted ( #6)
[ 25.790000] PC is at v6_dma_clean_range+0x4/0x20
[ 25.790000] LR is at dma_cache_maint+0x144/0x174
[ 25.790000] pc : [<c00335e0>] lr : [<c00309d4>] psr: 60000193
[ 25.790000] sp : c0417c80 ip : 00000001 fp : c0459864
[ 25.790000] r10: 0000005a r9 : 00000001 r8 : 00000000
[ 25.790000] r7 : c0024144 r6 : 80000193 r5 : c043ce60 r4 : 00000000
[ 25.790000] r3 : c00335dc r2 : f1500000 r1 : 0000005a r0 : 00000000
[ 25.790000] Flags: nZCv IRQs off FIQs on Mode SVC_32 ISA ARM Segment ker
[ 25.790000] Control: 00c5787d Table: 65f3000a DAC: 00000017
[ 25.790000] Process swapper (pid: 0, stack limit = 0xc0416270)
[ 25.790000] Stack: (0xc0417c80 to 0xc0418000)
[ 25.790000] 7c80: c0459864 00000002 00000000 c788b2a0 c5f0f800 c5f818a0 fe008
034 00000000
[ 25.790000] 7ca0: bf009924 bf004440 c0417ccc c5f0f800 a0000000 c5f0fc2c 60000
113 c0570120
[ 25.790000] 7cc0: c05700e0 00000000 c788b2a0 c5f0f800 c0459900 c788b2a0 c5f81
8a0 bf009924
[ 25.790000] 7ce0: c0459864 c025e708 c78fd360 c05700e0 00000000 c5ee31c0 c788b
2a0 00000000
[ 25.790000] 7d00: 00000000 c5ee321c c5f0f800 c788b2a0 c5f818a0 c026df84 00000
020 00000020
[ 25.790000] 7d20: ffff94e3 c0416000 a0000113 c5f818a0 00000000 c5ee31c0 c5ee3
21c c54f88c0
[ 25.790000] 7d40: c54f88c4 c55a0964 c5f0f800 c025e9ec c025e7d4 c5f818a0 c55a0
940 c55a5a60
[ 25.790000] 7d60: 0000000e c0264f7c 00000000 0000004c c5f25e00 c5f818a0 00000
000 c5f25e00
[ 25.790000] 7d80: c0459404 0000004c c5f818a0 00000001 c55a5a60 c02cb8d8 c5f81
8a0 c0416000
[ 25.790000] 7da0: c5f25e00 c0459404 0000004c c552a040 00000001 c02cd620 c02dc
b4c c045960c
[ 25.790000] 7dc0: c045c494 c5f25e00 ffffa09b 0000001c c5f0f800 a0000113 c55a5
a60 c0417e20
[ 25.790000] 7de0: c0416000 c5f25e00 c0459404 c5f818a0 c0416000 c5f25e00 c0459
404 0000004c
[ 25.790000] 7e00: c552a040 00000001 0000001c c02e86f0 00000000 00000002 c0417
e5c 00000000
[ 25.790000] 7e20: c55a5a60 00000002 00000000 00000000 000002ff 00000000 00000
000 16000000
[ 25.790000] 7e40: 00000000 00000000 00000000 00000000 00000000 0000003a 00000
08f 00000000
[ 25.790000] 7e60: c0417f50 00000000 c5f818a0 c54d4c14 c5f25e00 c5f25e54 00000
000 00000005
[ 25.790000] 7e80: 00000001 c02e94b4 00000001 2f16a3d4 00000019 c044b220 00000
000 c0416000

[ 25.790000] 7fe0: c041c024 60022f48 410fb025 60022f14 00000000 60008084 00000
000 00000000
[ 25.790000] [<c00335e0>] (v6_dma_clean_range+0x4/0x20) from [<c00309d4>] (dma
[ 25.790000] [<c00309d4>] (dma_cache_maint+0x144/0x174) from [<bf004440>] (cop
ro_hard_start_xmit+0xd0/0x41c [gmac])
[ 25.790000] [<bf004440>] (copro_hard_start_xmit+0xd0/0x41c [gmac]) from [<c02
5e708>] (dev_hard_start_xmit+0x230/0x2fc)
[ 25.790000] [<c025e708>] (dev_hard_start_xmit+0x230/0x2fc) from [<c026df84>]
[ 25.790000] [<c026df84>] (__qdisc_run+0x1e8/0x280) from [<c025e9ec>] (dev_que
[ 25.790000] [<c02e94b4>] (mld_ifc_timer_expire+0x1c8/0x2a4) from [<c0053b0c>]
[ 25.790000] [<c0053b0c>] (run_timer_softirq+0x10c/0x208) from [<c004f028>] (_
[ 25.790000] [<c004f028>] (__do_softirq+0xac/0x150) from [<c004f468>] (irq_exi
[ 25.790000] [<c004f468>] (irq_exit+0x84/0x8c) from [<c002b294>] (do_local_tim
[ 25.790000] [<c002b294>] (do_local_timer+0x54/0x74) from [<c03239d8>] (__irq_
[ 25.790000] Exception stack(0xc0417f50 to 0xc0417f98)
[ 25.790000] 7f40: 2e25bdfc 00000000 c0417
f98 00000000
[ 25.790000] 7f60: c0416000 c0416000 c043d0c4 c041c02c c0025540 00000002 c041b
d70 c043ce40
[ 25.790000] 7f80: 00000004 c0417f98 c002c53c c002c540 60000013 ffffffff

[ 25.790000] [<c03239d8>] (__irq_svc+0x38/0xc0) from [<c002c540>] (default_idl
[ 25.790000] [<c002c540>] (default_idle+0x24/0x28) from [<c002c6f0>] (cpu_idle
[ 25.790000] [<c002c6f0>] (cpu_idle+0x58/0x94) from [<c0008a08>] (start_kernel
[ 25.790000] [<c0008a08>] (start_kernel+0x31c/0x384) from [<60008084>] (0x6000
[ 25.790000] Code: e3a00000 ee070f9a e1a0f00e e3c0001f (ee070f3a)
[ 25.790000] Kernel panic - not syncing: Fatal exception in interrupt
[ 26.330000] Internal error: Oops - bad mode: 0 [#2] SMP
[ 26.330000] Modules linked in: bootled_module gmac mii
[ 26.340000] CPU: 1 Tainted: G D ( #6)
[ 26.340000] PC is at v6_dma_clean_range+0x4/0x20
[ 26.350000] LR is at default_idle+0x20/0x28
[ 26.350000] pc : [<c00335e0>] lr : [<c002c53c>] psr: 200001d1
[ 26.350000] sp : c7843f90 ip : 00000000 fp : 00000000
[ 26.360000] r10: 60022f14 r9 : 410fb025 r8 : 00000000
[ 26.370000] r7 : c00335dc r6 : c056f144 r5 : 00000000 r4 : c056f144
[ 26.380000] r3 : c043d51c r2 : 00000001 r1 : 0000005a r0 : 00000000
[ 26.380000] Flags: nzCv IRQs off FIQs off Mode FIQ_32 ISA ARM Segment ke
[ 26.390000] Control: 00c5787d Table: 654a400a DAC: 00000017
[ 26.390000] Process swapper (pid: 0, stack limit = 0xc7842270)
[ 26.400000] Stack: (0xc7843f90 to 0xc7844000)
[ 26.400000] 3f80: 00000000 0000005a 00000
001 c043d51c
[ 26.410000] 3fa0: c056f144 00000000 c056f144 c00335dc 00000000 410fb025 60022
f14 00000000
[ 26.420000] 3fc0: 00000000 c7843f90 c002c53c c00335e0 200001d1 ffffffff c002c
51c c002c6f0
[ 26.430000] 3fe0: 410fb025 6784400a 0000001f 00c0387d c043d5d8 60008084 00000
000 00000000
[ 26.440000] [<c00335e0>] (v6_dma_clean_range+0x4/0x20) from [<c002c53c>] (def
[ 26.450000] [<c002c53c>] (default_idle+0x20/0x28) from [<0000005a>] (0x5a)
[ 26.450000] Code: e3a00000 ee070f9a e1a0f00e e3c0001f (ee070f3a)
[ 26.460000] CPU1: stopping
[ 26.460000] [<c00305e4>] (unwind_backtrace+0x0/0xe0) from [<c002b39c>] (do_IP
[ 26.470000] [<c002b39c>] (do_IPI+0xe8/0x154) from [<c03239d8>] (__irq_svc+0x3
[ 26.480000] Exception stack(0xc7843f20 to 0xc7843f68)
[ 26.480000] 3f20: 00000000 c04467a0 c043d5cc 00000000 c7843f90 c7842000 c783b
9a0 c043d5c8
[ 26.490000] 3f40: 00000000 410fb025 c03a2db8 00000000 00000000 c7843f68 c002f
048 c002f060
[ 26.500000] 3f60: 60000153 ffffffff

[ 26.510000] [<c03239d8>] (__irq_svc+0x38/0xc0) from [<c002f060>] (die+0xfc/0x
[ 26.520000] [<c002f060>] (die+0xfc/0x160) from [<c002f1f4>] (bad_mode+0x3c/0x
[ 26.520000] [<c002f1f4>] (bad_mode+0x3c/0x4c) from [<c002c53c>] (default_idle
[ 26.530000] [<c002c53c>] (default_idle+0x20/0x28) from [<0000005a>] (0x5a)

Edited 1 time(s). Last edit at 10/04/2012 09:35PM by bchen.
Re: Booting Debian on Pogoplug Pro
October 04, 2012 11:44PM

Look under /usr/lib/modules! they have been moved.
Re: Booting Debian on Pogoplug Pro
October 05, 2012 09:33AM
argh, it's there! After I copied them, everything seemed to work! Ok, now I need to find what I can do with the system. It seems that this rootfs is based on Squeezeplug. I, however, didn't find some useful tools, like samba, SqueezeBox server. Do we have to install them by ourself? If so, any instructions/links to do that?

Thanks again bodhi!
Re: Booting Debian on Pogoplug Pro
October 05, 2012 03:43PM

If you like SqueezeBox, you could start with Debian Squeezeplug rootfs (sorry I don't have links), and do the manual steps. Just make sure that the version is 2.6.xxx. Or you can install the tools on top of your current rootfs. I recalled some users posted in this forum about Squeezeplug but can't remember the name.
Re: Booting Debian on Pogoplug Pro
October 12, 2012 08:45PM
I've been able to get an update Pogoplug Pro set up with Varkey's rootfs by updating the modules from the current Archlinux rootfs. And I was able to change the sources.list to reflect wheezy sources. I was able to update everything but udev. WarheadsSEsaid to use libaccept4. I compiled it and installed it and it appears to be running, but if I update udev, I cannot reboot the Pogoplug Pro. Am I missing a step? Is there something that needs to be done besides installing libaccept4?
Re: Booting Debian on Pogoplug Pro
October 12, 2012 11:35PM
I'm hoping WarheadsSE will come around here and answer this question, too!
Re: Booting Debian on Pogoplug Pro
October 13, 2012 09:33AM
Have you ensured that libaccept4 is part of /etc/ld.so.preload setup correctly?
Re: Booting Debian on Pogoplug Pro
October 13, 2012 09:42AM
What @bharath said. You have to add it to your ld.so.preload :)

See the package install @ https://github.com/archlinuxarm/PKGBUILDs/blob/master/alarm/libaccept4/libaccept4.install
Re: Booting Debian on Pogoplug Pro
October 13, 2012 04:32PM
Thanks guys! I have not tried to upgrade udev yet, this info will be handy :-)
Re: Booting Debian on Pogoplug Pro
October 14, 2012 05:59AM
Hmmm... I'm pretty sure I have libaccept4 installed and setup correctly. When it installs, it creates the /etc/ld.so.preload file automatically. And if I manually change the location where it is pointing to something inaccurate, I get an error message: ERROR: ld.so: object '/usr/usr/local/lib/libaccept4.so' from /etc/ld.so.preload cannot be preloaded: ignored. So it seems like it is installed and functioning correctly; but I have been unable to successfully update udev and reboot my Pogoplug Pro. The Pogoplug appears to make it through some of the boot process (the LED flashes then goes out like it normally does, but it never comes back on and the Pogoplug never seems to boot and/or acquire an IP address and therefore is not reachable via SSH). Then my only option is to restore the backup that I have before the udev update (with udev version 164). Unfortunately, I don't have a serial cable so I can't really diagnose the problem any better. My current solution is to block udev from updating, but if it's possible to get it updated, I'd like to be able to do it.
Re: Booting Debian on Pogoplug Pro
October 15, 2012 11:01AM
I have the plans of upgrading my pro to wheezy, I just havent had the time to mess with it. I will see if I can get some time this weekend and do the needful to update. I have a serial console so if it breaks I should be able to at least find out what is going wrong.
Re: Booting Debian on Pogoplug Pro
October 19, 2012 05:14PM
You might want to look into the changes needed by the newer udev.
Re: Booting Debian on Pogoplug Pro
October 20, 2012 10:31AM
IIRC wheezy uses udev-175 are there any changes that on needs to watch out for?
Re: Booting Debian on Pogoplug Pro
October 20, 2012 01:25PM
I have upgraded to wheezy without any issues, for one to upgrade you need to install libaccept4 and do the following

1) Create /etc/ld.so.preload
2) Edit /etc/init.d/udev and edit the unsupported kernel check to not include 2.6.31

I need to resolve a few issues, any ideas on this would be greatly appreciated

1) findfs is reporting it cant resolve the UUID of my rootfs for some reason as mentioned in the fstab.
2) startpar: service(s) returned failure: hdparm procps rpcbind mountnfs-bootclean.sh ... failed!
3) ntp isnt setting the time, I need to login and set the time correctly.

Any suggestions towards resolving these issues would be appreciated.
Re: Booting Debian on Pogoplug Pro
October 20, 2012 05:58PM

It's hard to tell without the system log. You could attach it here.
Re: Booting Debian on Pogoplug Pro
October 20, 2012 07:08PM
There is nothing in the syslog that stands out to me, may be you could spot something that I am missing.

syslog: http://pastebin.com/aRA1a5c6
Re: Booting Debian on Pogoplug Pro
October 21, 2012 06:30PM
That looks like your dmesg log, do you have syslogd running output to /var/log/messages or to RAM (with logread)? I think your ntpd problem can be sorted out if you look at the sys log.
Re: Booting Debian on Pogoplug Pro
October 22, 2012 12:33AM
I am running rsyslog that was /var/log/syslog, It is not much different from /var/log/messages

Here is /var/log/messages: http://pastebin.com/TkWaZGuc
Re: Booting Debian on Pogoplug Pro
October 22, 2012 02:54AM
Nothing in your log indicating that ntpd is running at all?
Re: Booting Debian on Pogoplug Pro
October 22, 2012 11:58PM
But if you see the earlier syslog that I posted you will see that ntpd does start off.
Re: Booting Debian on Pogoplug Pro
October 23, 2012 08:25AM
I just installed ntpdate and that seems to resolve the issue time being set. Need to figure out issue on startpar failures.
Re: Booting Debian on Pogoplug Pro
October 23, 2012 03:58PM
Here are my personal notes to myself on the subject of RTC setting, which may prove helpful to you. There may still be issues of the order in which NTP vs. Ethernet comes up, but on my boxes, this forces a good RTC fairly quickly after a boot. YMMV.

20 Mar 2011:
The Dockstar does not have a RTC, so the network must be used to set the
date and time on every boot.  To set the date, "ntpdate" is invoked from
/etc/network/if-up.d/ntpdate .  If you then apt-get "ntp", it fails to
start because "ntpdate" is using its resources when it is invoked.  Even
if ntpd is invoked from rc.local, it still can't start up successfully.
As a work-around, we put in a cron entry to check that ntpd is running
hourly, and start it up if it is not.  This should be sufficient, since
ntpdate sets the date exactly on every boot.

21 Mar 2011:
A better fix:  Follow the lead from the sheevaplug and invoke ntpd in
/etc/network/if-up.d/ntpdate in lieu of ntpdate.  Note: ntp must be
invoked with '-g' option to allow it to forcibly set the date, even if
it is far off from the current date, like 1969.

   # The following line commented out by RES 21 March 2011
   # /usr/sbin/ntpdate-debian -s $OPTS 2>/dev/null || :

   # The following line added by RES 21 Mar 2011
   invoke-rc.d --quiet ntp restart || true

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.