Welcome! Log In Create A New Profile


Installing debian-lenny from rescue System

Posted by hoser0316 
Installing debian-lenny from rescue System
October 05, 2010 07:22PM
Tried runing the installation to a 4Gb flash drive from afer booting from rescue system but it is falling wit several packages failing to download
here are some of them failing, has anyone installed Lenny from the rescue system?

If everything looks good, type 'ok' to continue: ok
Connecting to jeff.doozan.com (
install_uboot_mtd0.s 100% |***************************************************************************************************************************************************| 15859 --:--
Installing Bootloader
# checking for /usr/sbin/blparam...
# checking for /usr/sbin/nandwrite...
# checking for /usr/sbin/nanddump...
# checking for /usr/sbin/flash_erase...
# checking for /usr/sbin/fw_printenv...
# checking for /etc/fw_env.config...

# Attempting to auto-detect your device.../tmp/install_uboot_mtd0.sh: line 285: /usr/sbin/blparam: not found
/tmp/install_uboot_mtd0.sh: line 286: /usr/sbin/blparam: not found

Your device could not be auto-detected.

You must be using a Seagate Dockstar or Pogoplug Pink to run this installer.

What device are you using? Type the number of your device and press ENTER.
1 - DockStar
2 - Pogoplug v2 - Pink
3 - Other
Selected Dockstar

# Checking for existing uBoot on mtd0...
Connecting to jeff.doozan.com (
uboot.mtd0.kwb.md5 100% |***************************************************************************************************************************************************| 49 --:--
Block size 131072, page size 2048, OOB size 64
Dumping data starting at 0x00000000 and ending at 0x00080000...
## The newest uBoot is already installed on mtd0.

# uBoot installation has completed successfully.
# checking for /usr/sbin/blparam...
mke2fs 1.41.12 (17-May-2010)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
229376 inodes, 917276 blocks
45863 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=939524096
28 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736

Writing inode tables: done
Writing superblocks and filesystem accounting information: done

This filesystem will be automatically checked every 23 mounts or
180 days, whichever comes first. Use tune2fs -c or -i to override.
Setting up swapspace version 1, size = 250425344 bytes

# Starting debootstrap installation
I: Retrieving Release
I: Retrieving Packages
I: Validating Packages
I: Resolving dependencies of required packages...
I: Resolving dependencies of base packages...
I: Found additional required dependencies: insserv libbz2-1.0 libdb4.8 libslang2
I: Found additional base dependencies: adduser cpio debian-archive-keyring gnupg gpgv initramfs-tools klibc-utils libbsd0 libcap2 libedit2 libgssapi-krb5-2 libk5crypto3 libkeyutils1 libklib5-3 libkrb5support0 libncursesw5 libreadline6 libssl0.9.8 libudev0 libusb-0.1-4 libuuid-perl libwrap0 linux-base linux-image-2.6.32-5-kirkwood openssh-blacklist openssh-client procps readmon vim-common
I: Checking component main on http://ftp.us.debian.org/debian...
I: Retrieving libacl1
I: Validating libacl1
I: Retrieving adduser
I: Validating adduser
I: Retrieving apt
I: Validating apt
I: Retrieving libattr1
W: Couldn't download package libattr1
I: Retrieving base-files
I: Validating base-files
I: Retrieving base-passwd
I: Validating base-passwd
I: Retrieving bash
I: Validating bash
I: Retrieving libbz2-1.0
W: Couldn't download package libbz2-1.0
I: Retrieving coreutils
W: Couldn't download package coreutils
I: Retrieving cpio
I: Validating cpio
I: Retrieving dash
I: Validating dash
I: Retrieving libdb4.8
I: Validating libdb4.8
I: Retrieving debconf-i18n
W: Couldn't download package debconf-i18n
I: Retrieving debconf
W: Couldn't download package debconf
I: Retrieving debian-archive-keyring
I: Validating debian-archive-keyring
I: Retrieving debianutils
I: Validating debianutils
I: Retrieving dhcpcd
I: Validating dhcpcd
I: Retrieving diffutils
W: Couldn't download package diffutils
I: Retrieving dpkg
W: Couldn't download package dpkg
I: Retrieving e2fslibs
I: Validating e2fslibs
I: Retrieving e2fsprogs
I: Validating e2fsprogs
I: Retrieving libcomerr2
I: Validating libcomerr2
I: Retrieving libss2
W: Couldn't download package libss2
I: Retrieving libc-bin
W: Couldn't download package libc-bin
I: Retrieving libc6
I: Validating libc6
I: Retrieving findutils
Re: Installing debian-lenny from rescue System
October 05, 2010 08:04PM
Well I believe I solved the problem
when checking the log file I notice that on the wget failures there was an error with the ip address returned by ftp.us.debian,org

since these are on a round robin one or more are not working as mirrros and those were the failures when dowlonding

[Trixbox tmp]# host ftp.us.debian.org
ftp.us.debian.org has address
ftp.us.debian.org has address
ftp.us.debian.org has address
ftp.us.debian.org has address
ftp.us.debian.org has address
ftp.us.debian.org has address

I modified the line on the install script to use only one mirror that I knew it worked and all the packages downloaded and installed fine




so if this happens to you downloading the packages may want to edit the script and use one IP that you see it is working.
Re: Installing debian-lenny from rescue System
November 21, 2010 08:55PM
Thank you, thank you, thank you for posting this. I was in the rescue system and was pulling my hair out to get it solved. Edited the .sh install script with the proper mirror and got a fresh re-install up in no time.

I've been lurking and reading for the last week or so since I got my Dockstar and registered just to say thank you. Really appreciate it!

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.