Rescue system not starting
January 26, 2011 11:36PM
I'm having trouble starting the rescue system. Uboot starts fine (see below) and show starting kernel....and the LED goes away (dark). My DHCP servers doesn't show any request. I have tried to manually connect/ping to the but I don't get any response (I did change my primary system IP to

The strangest thing is that it worked the 1st time a few days ago. Now that I really need it... I'm hosed. Any help?

U-Boot 2010.09 (Oct 23 2010 - 11:49:22)
Marvell-Dockstar/Pogoplug by Jeff Doozan
Hit any key to stop autoboot: 0
(Re)start USB...
USB: Register 10011 NbrPorts 1
scanning bus for devices... 2 USB Device(s) found
scanning bus for storage devices... 0 Storage Device(s) found
** Block device usb 0 not supported

** Invalid boot device **
Creating 1 MTD partitions on "nand0":
0x000002500000-0x000010000000 : "mtd=3"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size: 131072 bytes (128 KiB)
UBI: logical eraseblock size: 129024 bytes
UBI: smallest flash I/O unit: 2048
UBI: sub-page size: 512
UBI: VID header offset: 512 (aligned 512)
UBI: data offset: 2048
UBI: attached mtd1 to ubi0
UBI: MTD device name: "mtd=3"
UBI: MTD device size: 219 MiB
UBI: number of good PEBs: 1750
UBI: number of bad PEBs: 2
UBI: max. allowed volumes: 128
UBI: wear-leveling threshold: 4096
UBI: number of internal volumes: 1
UBI: number of user volumes: 0
UBI: available PEBs: 1729
UBI: total number of reserved PEBs: 21
UBI: number of PEBs reserved for bad PEB handling: 17
UBI: max/mean erase counter: 1/1
UBIFS error (pid 0): ubifs_get_sb: cannot open "ubi:rootfs", error -19
Error reading superblock on volume 'ubi:rootfs'!
** Block device usb 0 not supported
** Block device usb 1 not supported
** Block device usb 2 not supported
** Block device usb 3 not supported
** Block device usb 0 not supported
** Block device usb 0 not supported
Wrong Image Format for bootm command
ERROR: can't get kernel image!
stopping USB..

NAND read: device 0 offset 0x100000, size 0x400000
4194304 bytes read: OK
## Booting kernel from Legacy Image at 00800000 ...
Image Name: Linux-
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 3175992 Bytes = 3 MiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
Loading Kernel Image ... OK

Starting kernel ...
Re: Rescue system not starting
February 05, 2011 03:21PM
Looks like my issue is related to the changing the Arcnumber to 2998. The last time I was able to successful boot was before I changed the Arc#.

I do hope this issue gets resolve soon.

Re: Rescue system not starting
February 08, 2011 11:08AM
I have the same problem here. I changed the arcNumber and now it wont boot. What are the things i can do?
Re: Rescue system not starting
February 17, 2011 09:24AM
The simpliest way is to use a serial cable and set the arcNumber back.

If you already have set up netcat you can use it instead of a serial cable!

Next step is to compile the rescue system for yourself and install it. (Not an easy task but can be done. I am not an experienced linux freak and made it work!)

My version works with 2998!

Have look here (and at the start post of that topic!)

Edited 1 time(s). Last edit at 02/17/2011 09:34AM by Riffer.
Re: Rescue system not starting
March 03, 2011 04:19PM
I loaded Jeff's Rescue System V2 this past weekend, and it works fine now with the new arcNumber.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.