GNU/Linux on an A10 Tablet (LY-F1)
July 10, 2012 03:40AM
Hi everyone,
first of all, I really appreciate all the work that is being done around the allwinner a10 by the community.
I am wondering though if anybody has been able to run Linux from an sd-card on the LY-F1 tablet (see here:
When I insert an sd card (class 4 card) the tablet just doesn't power up at all. When I remove the card, Android is booted normally though. The HDMI port seems to be working as well as I can use TV output with Android. Furthermore, I looked up the /var/log directory on the card after my attempts and there seem to be no log files recorded, so I am pretty sure the Linux kernel doesn't boot up at all.

So far I've been trying various distributions:

- Linaro Alip with Mele A1000 hardware pack as suggested here
- the Lubuntu distribution from miniand
- as well as the Ubuntu distribution from this forum (see here)

I tried with the script.bin files that were included as well as with a script.bin file I extracted from the tablet with adb.

Anybody else experiencing this problem? Or has anybody got Linux working on the LY-F1?

Edited 1 time(s). Last edit at 07/12/2012 02:32PM by gnexus.
Re: Linux on an A10 Tablet (LY-F1)
July 10, 2012 06:19AM
I can't see why it would not boot from SD. Do you have the HDMI connected?

You won't get any output from the tablet LCD no matter what you try. I can promise you that much.

If you do not get a screen in HDMI then try putting an auto config in /etc/network/interfaces for your wlan device on the tablet.
It must have the correct config with your wlan password. Look on the net for examples of how to do that if you don't know how. Then see if you can ping it and log in via SSH.

Also, sometimes the tablets are VERY tricky to power on from SD. You need to power it off in Android with the power adapter disconnected. Then power it back on with the SD inserted by holding the power button down for about 5 secs.

Keep trying and report back on your progress.

Good luck!
Re: Linux on an A10 Tablet (LY-F1)
July 10, 2012 06:38AM
Thanks for your answer. I will try again on the weekend (on the road the whole week...) and post my results.
Andy Kirby
Re: Linux on an A10 Tablet (LY-F1)
July 10, 2012 09:53AM
I think this will be because the current Linux images are configured for HDMI output, you will most likely need to modify the evb.bin file (found in the 16mb boot partition) and configure it to use the LCD display at its native resolution.

Andy Kirby
Re: Linux on an A10 Tablet (LY-F1)
July 10, 2012 09:54AM
This is what i'm talking about:,8635

good luck!
Re: Linux on an A10 Tablet (LY-F1)
July 10, 2012 10:18AM

I think this will be because the current Linux images are configured for HDMI output, you will most likely need to modify the evb.bin file (found in the 16mb boot partition) and configure it to use the LCD display at its native resolution.

Most people have not had much luck at getting the LCD's on the tablets to work with Linux. There is more to it than just the script.bin. You also have to have a kernel with a config and modules that support the LCD. I don't think that support is there in our SD images. So far I have not been able to get the LCD on my tablet to work. But then again I have not really tried a lot.

If you have a tablet with a working LCD using Debian, Ubuntu or some other GNU/LInux distro I would be VERY interested to see your script.bin and kernel config.
Re: Linux on an A10 Tablet (LY-F1)
July 10, 2012 12:54PM
At the moment I actually don't worry too much about the LCD display and the script.bin file. I have HDMI connected and if that works with Linux that would be great for me (it does with Android!). My main problem at the moment is that the tablet doesn't boot at all with the sd card inserted (no recordings in /var/log) ...

Thanks anyway, I'll try a few things and keep you posted.
Re: Linux on an A10 Tablet (LY-F1)
July 10, 2012 01:06PM
Don't be too concerned about /var/log. Currently not much, if any, helpful log info goes into /var/log. So even if it is blank I'm not sure if that would confirm the tablet is not booting. The way I was able to eventually log into my tablet was by constanly pinging it. Then I was able to SSH in. It was only later that I finally saw the HDMI screen.

Then most important thing would be to be absolutely certain your /etc/network/interfaces file has something like this:
auto wlan0
iface wlan0 inet dhcp
        pre-up ifconfig wlan0 hw ether xx:xx:xx:xx:xx:xx  up || true
            wireless-ssid xxxxxxxxxx
            wireless-psk xxxxxxxxxx
Make certain the mac is the same as the one you see for wlan in android.
Andy Kirby
Re: Linux on an A10 Tablet (LY-F1)
July 12, 2012 10:55AM
Just an update as i've been thinking about this more, it looks like it has been done... see the following youtube video.

I would definately be interested in getting hold of one of these and getting linux up and running.
Re: Linux on an A10 Tablet (LY-F1)
July 14, 2012 09:09AM
I have a generic A10 tablet and I got it to work using the image provided here and also the image found in you can find 4 different versions a combination of 1080p, 720p, 1GB, 512MB. According to the specs of your tablet you can use one of those.

Also I got the LCD working changing the evb.bin file as follows:

screen0_output_type = 3
screen0_output_mode = 4
screen1_output_type = 1
screen1_output_mode = 4

screen0_output_type = 1
screen0_output_mode = 0
screen1_output_type = 3
screen1_output_mode = 4

You can find in this forum a topic on how to modify the evb.bin file.

No I want to get the touch screen to work. I anyone knows how to I would really appreciate that information!

Re: GNU/Linux on an A10 Tablet (LY-F1)
July 15, 2012 07:05AM
Thanks everyone for their help but unfortunately I still can't get it to work. I tried modifying /etc/network/interfaces and then ping it but no luck. My interfaces file
looks like this:

iface wlan0 inet dhcp
pre-up ifconfig wlan0 hw ether MYMACADDRESS  up || true
wireless-mode Managed
wireless-key MYPASSPHRASE

I'm quite confident that this should work (it does on my Ubuntu laptop). The tablet still won't do anything though...
Re: GNU/Linux on an A10 Tablet (LY-F1)
July 15, 2012 09:33AM
You may also want to just try opening up your AP with no security temporarily for testing.
Keep in mind you may need to ping it multiple times before it responds. The wifi module has very aggressive power saving.
It will sleep immediately. So you must ping it immediately. Also you need to check /etc/udev/rules.d/70-persistent-net.rules.
Try using your MAC in wlan0, and also try having a different mac for wlan0 and yours as wlan1.

If you have HDMI that should work. If it does not then I would first be checking the SD card to see it was written properly.
Since others have got that tablet to work I would think it must be a problem with the SD image.
What SD image are you using? The Debian image has fewer issues than the Ubuntu.
When you wrote the SD did you run sync after dd finished?
Keep trying. It is worth it. You should be able to get it going eventually.
Re: GNU/Linux on an A10 Tablet (LY-F1)
May 04, 2013 06:28AM
Hi folks...
I know, the topic is old but the subject not that much.
I've been working witg GNU/Linux since Torvalds released kernel 1.0 but I never had the chance to work with ARM devices until last year.
Since I bought this Ly-F1 tablet I wanted to run SuSE on it with Gnome3.

No luck yet but thre is hope.
I had rigged this tab with a serial connection (an old phone 232 interface) so I could debug and interact with the tab from u-boot onwards.
Up to this point, any kernel I try to boot, compiled by me or others from the web, hangs in random places.
If I reboot from the watchdog the oops or hang happens at the same point but in a power cycle it will go random.
The reasons, I think, are: wrong PLL settings in U-boot, script.bin and perhaps something missing in comunity kernel regarding run-time setup on these controls.
Wrong memory settings in u-boot and script.bin and sunxi-kernel doesn't look like giving a damn about mem= command.
I did try to manually load the kernel at different offsets (base addresses) but the address range able to hold the uImage and script.bin is narrow and I ended up writing a kernel in very wrong places (I'm yet to understand the virtual memory mapping in this device) so kinda freaked out a couple of times :D
As my ly-f1 has 2 sdram banks of 512mb each, the kernel seems unable to see the other bank. Android kernel looks like detecting fine 1024mb but in the original script.bin there are only 512mb defined.
In these boards, chains of bootloaders mess with th iternal knobs from voltage to clock speeds - so a fair understanding about which, what does and who and how are controlled will be the key factor in booting a GNU system on these toys.
Anyway, from underneath the Andoid kernel I mamaged to use Xorg on the framebuffer in a chroot and things look simple once I'd get a kernel to boot. Mali support is possible, hw decoding is possible (Perhaps vaapi?) so... ther is hope.
If not, I think I'll spend another buck and go to a Tegra device...
Cheers and good luck!

Edited 1 time(s). Last edit at 05/04/2013 06:35AM by Sandel.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.