Welcome! Log In Create A New Profile

Advanced

Netgear Stora MS2110 rootfs Bad Magic Number

Posted by Teddy 
StormyWolf
Re: Netgear Stora MS2110 rootfs Bad Magic Number
May 24, 2021 12:20AM
Hey Bodhi,

I've been following multiple post on here where you've been helping people unbrick or upgrade their devices.
I have inherited a Netgear Stora from someone that they had reset (and therefore couldn't access the online accounts anymore) and I did successfully root it. But during my mad searching and testing, following instructions online to install debian (before I found you guide) I managed to mess it up completely having pretty much the same issues Paul and some others have faced.

Currently I get the everything is deleted, can't create new settings and for whatever reason doesn't I can't get the usb to load. On the rare occasion it detects the storage device, it tells me it's a bad partition and can't boot from it.

I can access it from the serial cable to view it but kwboot just gives the "restart" and then the handshake code with no boot and nothing happens after.

I'm still getting used to linux systems, been away from them for a few years so don't know if it's my own mistakes by forgetting a simple thing or my usb is useless or i've just bricked it but would appreciate your help if you can!

-Mitch
Re: Netgear Stora MS2110 rootfs Bad Magic Number
May 24, 2021 02:05AM
Hey Mitch,

Sounds like it is only semibricked.

> I can access it from the serial cable to view it
> but kwboot just gives the "restart" and then the
> handshake code with no boot and nothing happens
> after.

The best way forward is to get it to boot to the Debian USB rootfs.

So create the rootfs on USB using Debian-5.2.9-kirkwood-tld-1-rootfs-bodhi.tar.bz2 from the release thread:

https://forum.doozan.com/read.php?2,12096

And the connect serial console, attach the USB rootfs. And power up. Interrupt serial console and

printenv
usb reset
If the USB is detected as storage device,
usb part
ext2ls usb 0:1 /boot

If the USB is not detected, do a few
usb reset
(wait a few seconds in between each usb reset).
and repeat
usb part
ext2ls usb 0:1 /boot


And then post the entire serial console log here.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Netgear Stora MS2110 rootfs Bad Magic Number
July 27, 2021 06:36PM
Hi Bodhi,

I have some trouble with unbricking my stora. I did a resetenv and now the U-boot is corrupted. I have read through several posts here and tried everything. My first plan was to follow the steps described by stormy here: https://forum.doozan.com/read.php?3,104929,105219#msg-105219, by using the flashware.img file. The problem (I think) is that the USB drive can't be read, it starts to load and then it errors out.
** ext2fs_devread() read error - block

It is the same no matter which USB drive I use, and I also tried removing the partition table, creating a new partition, and creating a new ext2 filesystem as you suggested earlier in this thread.

Here is the entire U-boot log:

�
         __  __                      _ _
        |  \/  | __ _ _ ____   _____| | |
        | |\/| |/ _` | '__\ \ / / _ \ | |
        | |  | | (_| | |   \ V /  __/ | |
        |_|  |_|\__,_|_|    \_/ \___|_|_|
 _   _     ____              _
| | | |   | __ )  ___   ___ | |_ 
| | | |___|  _ \ / _ \ / _ \| __| 
| |_| |___| |_) | (_) | (_) | |_ 
 \___/    |____/ \___/ \___/ \__| 
 ** MARVELL BOARD: RD-88F6281A LE 

U-Boot 1.1.4 (Sep  4 2009 - 09:36:11) Marvell version: 3.4.14

U-Boot code: 00600000 -> 0067FFF0  BSS: -> 006CEE60

Soc: 88F6281 A0 (DDR2)
CPU running @ 1000Mhz L2 running @ 333Mhz
SysClock = 333Mhz , TClock = 200Mhz 

DRAM CAS Latency = 5 tRP = 5 tRAS = 18 tRCD=6
DRAM CS[0] base 0x00000000   size  64MB 
DRAM CS[1] base 0x04000000   size  64MB 
DRAM Total size 128MB  16bit width
Flash:  0 kB
Addresses 8M - 0M are saved for the U-Boot usage.
Mem malloc Initialization (8M - 7M): Done
NAND:256 MB
CRC in Flash: fffbffff, Calculated CRC: 3232a159
+++++++++++++++++++++++++++Checksum Error!++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++Checksum Error!++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++Checksum Error!++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++Checksum Error!++++++++++++++++++++++++++++++
+++++++++++++++++++++++++++Checksum Error!++++++++++++++++++++++++++++++
## Error: environment overflow, "stdin" deleted
## Error: environment overflow, "stdout" deleted
## Error: environment overflow, "stderr" deleted

CPU : Marvell Feroceon (Rev 1)
## Error: environment overflow, "console" deleted
## Error: environment overflow, "mainlineLinux" deleted
## Error: environment overflow, "CASset" deleted
## Error: environment overflow, "enaMonExt" deleted
## Error: environment overflow, "enaCpuStream" deleted
## Error: environment overflow, "enaWrAllo" deleted
## Error: environment overflow, "pexMode" deleted
## Error: environment overflow, "disL2Cache" deleted
## Error: environment overflow, "setL2CacheWT" deleted
## Error: environment overflow, "disL2Prefetch" deleted
## Error: environment overflow, "enaICPref" deleted
## Error: environment overflow, "enaDCPref" deleted
## Error: environment overflow, "sata_dma_mode" deleted
## Error: environment overflow, "MALLOC_len" deleted
## Error: environment overflow, "ethprime" deleted
## Error: environment overflow, "netbsd_en" deleted
## Error: environment overflow, "vxworks_en" deleted
## Error: environment overflow, "bootargs_root" deleted
## Error: environment overflow, "bootargs_end" deleted
## Error: environment overflow, "image_name" deleted
## Error: environment overflow, "bootcmd" deleted
## Error: environment overflow, "standalone" deleted
## Error: environment overflow, "bootdelay" deleted
## Error: environment overflow, "disaMvPnp" deleted
## Error: environment overflow, "disaMvPnp" deleted
## Error: environment overflow, "ethaddr" deleted
## Error: environment overflow, "ethmtu" deleted
## Error: environment overflow, "eth1addr" deleted
## Error: environment overflow, "eth1mtu" deleted
## Error: environment overflow, "mvPhoneConfig" deleted
## Error: environment overflow, "mvNetConfig" deleted
## Error: environment overflow, "usb0Mode" deleted
## Error: environment overflow, "yuk_ethaddr" deleted
## Error: environment overflow, "nandEcc" deleted
## Error: environment overflow, "hddPowerCtrl" deleted
## Error: environment overflow, "netretry" deleted
## Error: environment overflow, "rcvrip" deleted
## Error: environment overflow, "loadaddr" deleted
## Error: environment overflow, "autoload" deleted
## Error: environment overflow, "enaAutoRecovery" deleted

Streaming disabled 
Write allocate disabled

Module 0 is RGMII
Module 1 is TDM

USB 0: device mode
PEX 0: interface detected no Link.
Net:   ## Error: environment overflow, "ethact" deleted
egiga0, egiga1## Error: environment overflow, "ethact" deleted

USB:   scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
Trying to load image from USB flash drive using FAT FS
reading /flashware.img

** Unable to read "/flashware.img" from usb 0:1 **
Trying to load image from USB flash drive using ext2 FS partition 0
Failed to mount ext2 filesystem...
** Bad ext2 partition or disk - usb 0:0 **
Trying to load image from USB flash drive using ext2 FS partition 1
....
.
...................
.........................
..............
 ** ext2fs_devread() read error - block

** Unable to read "/flashware.img" from usb 0:1 **
Couldn't load recovery image from USB flash drive, Trying network interface
Aquiring an IP address using DHCP...
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
*** ERROR: `ethaddr' not set
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
*** ERROR: `eth1addr' not set
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
*** ERROR: `ethaddr' not set
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
Failed to retreive an IP address assuming default (<NULL>)!
Starting the Recovery process to retreive the file...
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
*** ERROR: `eth1addr' not set
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
Failed
Power Button is pressed!
MPP Sel: 00000530, Data IN Enable: 00020058, Data In Polarity: 00000040, Data In: 00000010
Power Button is released!
MAC: 00:01:F5:95:D0:1C, IP: 10.149.208.28
## Error: environment overflow, "ethaddr" deleted
## Error: environment overflow, "ipaddr" deleted
## Error: environment overflow, "serverip" deleted
## Error: environment overflow, "netmask" deleted
## Error: environment overflow, "image_name" deleted
## Error: environment overflow, "console" deleted
## Error: environment overflow, "bootargs_root" deleted
## Error: environment overflow, "rootpath" deleted
## Error: environment overflow, "ethact" deleted
egiga0 no link
## Error: environment overflow, "ethact" deleted
egiga1 no link
## Error: environment overflow, "ethact" deleted
*** ERROR: `serverip' not set
## Error: environment overflow, "bootargs" deleted
## Booting image at 00800000 ...
Bad Magic Number
Marvell>> ext2ls usb 0:1

Device NOT ready
   Request Sense returned 00 00 00
** Can't read partition table on 0:0 **
** Bad partition - usb 0:1 **

-rajt
Re: Netgear Stora MS2110 rootfs Bad Magic Number
July 28, 2021 04:11PM
rajt,

> I have some trouble with unbricking my stora. I
> did a resetenv and now the U-boot is corrupted. I
> have read through several posts here and tried
> everything. My first plan was to follow the steps
> described by stormy here:
> https://forum.doozan.com/read.php?3,104929,105219#msg-105219,
> by using the flashware.img file. The problem (I
> think) is that the USB drive can't be read, it
> starts to load and then it errors out.
>
> ** ext2fs_devread() read error - block
>


That's the correct procedure. You might want to try to format the USB drive with FAT (not Ext2/Ext3).

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Netgear Stora MS2110 rootfs Bad Magic Number
July 31, 2021 03:25PM
bodhi,

> You might want to
> try to format the USB drive with FAT (not
> Ext2/Ext3).

I tried a USB drive formatted with FAT and got this error:
USB 0: device mode
PEX 0: interface detected no Link.
Net:   ## Error: environment overflow, "ethact" deleted
egiga0, egiga1## Error: environment overflow, "ethact" deleted

USB:   scanning bus for devices... 2 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
Trying to load image from USB flash drive using FAT FS
reading /flashware.img
.
data abort
pc : [<0064763c>]	   lr : [<0063e848>]
sp : 005fe62c  ip : 005fe54c	 fp : 005fe648
r10: 00000082  r9 : 00000000	 r8 : 005fffcc
r7 : 005fe698  r6 : 00000082	 r5 : 005fe698  r4 : 00000000
r3 : 005fe8a0  r2 : 00000c00	 r1 : 00000000  r0 : 00000006
Flags: nZCv  IRQs off  FIQs off  Mode SVC_32
Resetting CPU ...

It seems to be the same problem?
Any other suggestions?

rajt
Re: Netgear Stora MS2110 rootfs Bad Magic Number
July 31, 2021 04:16PM
rajt,

It means there is problem in this u-boot FAT driver that it crashed.

So I checked Stormy's post

Quote

-create USB flash drive with ext2 filesystem and a single primary partition(I used easeus partition master 14 which by default makes the USB partition logical and uboot cannot see it - so be carefull to make the usb partition primary)

You should use fdisk to wipe and recreate the partition (don't use any other command or GUI to do this). And then format the partition with Ext2 using command mkfs.ext2.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Netgear Stora MS2110 rootfs Bad Magic Number
August 01, 2021 06:35AM
Thank you bodhi (and stormy)!

I tried it one more time and it worked! Back to stock os :)
The funny thing is that I already did this ten times. Now I will try to boot in to the Debian rootfs.

-rajt
Re: Netgear Stora MS2110 rootfs Bad Magic Number
August 01, 2021 04:03PM
bodhi

I got the rootfs working. When I run apt-get upgrade, the USB port seems to reset, and then I need to reinstall the roots to get it to boot again.
The error always occurs when unpacking libbz2.

Preparing to unpack .../bzip2_1.0.6-9.2~deb10u1_armel.deb ...
Unpacking bzip2 (1.0.6-9.2~deb10u1) over (1.0.6-9.1) ...
Preparing to unpack .../libbz2-1.0_1.0.6-9.2~deb10u1_armel.deb ...
Unpacking libbz2-1.0:armel (1.0.6-9.2~deb10u1) over (1.0.6-9.1) ...
[  267.449892][  T122] usb 1-1: reset high-speed USB device number 2 using orion-ehci
[  298.259891][  T122] usb 1-1: reset high-speed USB device number 2 using orion-ehci

Thank you for all the help!

rajt
Re: Netgear Stora MS2110 rootfs Bad Magic Number
August 01, 2021 04:35PM
rajt,

> The error always occurs when unpacking libbz2.

That's odd. I have seen that myself or heard anybody reported this.

Swap migh or might not related to this problem.

Just a reminder, after you installed the rootfs on USB, you should set up swap file/partition before doing apt-get upgrade (I was not clear about this in the installation instruction). But a lot of time, swap space is needed because upgrade takes a lot of RAM.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Netgear Stora MS2110 rootfs Bad Magic Number
August 01, 2021 04:43PM
bodhi

> Just a reminder, after you installed the rootfs on
> USB, you should set up swap file/partition before
> doing apt-get upgrade (I was not clear about this
> in the installation instruction). But a lot of
> time, swap space is needed because upgrade takes a
> lot of RAM.

I did setup swap, 256MB, but maybe it is not enough?

-rajt
Re: Netgear Stora MS2110 rootfs Bad Magic Number
August 01, 2021 04:52PM
rajt,

> I did setup swap, 256MB, but maybe it is not
> enough?

Usually you'd want at least 4xRAM, so box with 128M should have a swap file of 512MB or larger. The old convention is 2xRAM, but with this new kernel configuration, 4xRAM or greater is the best. Larger swap space does not hurt, either.

With that said, if you have 256MB RAM, then it might not be related to this bzip2 installtion problem. But do try 512MB swap file or larger.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Netgear Stora MS2110 rootfs Bad Magic Number
August 01, 2021 06:45PM
bodhi,

Well, thank you! I first set up a 512MB swap, which did not work. Then I tried 1GB, and now it works.

-rajt
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: