Welcome! Log In Create A New Profile


Beauty and the Beast - any beast IN (Dockstar, GoGlex Net/Home, Pogo E02, ...) is ok

Posted by chessplayer 
Hi everyone,

while trying to fool around with the LEDs on my POGO E02, I stumbled upon a blog post by Obihörnchen and had a look at paragraph 13: "Enable color in Bash prompt". ---> WOW, I thought, this really does look nice. But why should the Archlinux guys have all the fun?

So the next thing I did was google for debian ASCII art in order to replace the (amazing) ALARM logo, only to find out that there is indeed something even better for debian: a package called linuxlogo!

First action, therefore, is:

apt-get install linuxlogo
# try it

So far, so good.

Then, I modified the bash.bashrc from Obihörnchen and copied his DIR_COLORS and put both of them in /etc.

This then looks much better already. However, I still get all the boring stuff like the copyright message from motd. But, for this Thomas Hunter provided a christmas present. So, I emptied out the file /etc/motd (which physically is /var/run/motd) and that was another step forward. Then another little modification of bash.bashrc as suggested in the above mentioned post. This gives the final result: BEAUTIFUL (in my eyes).

I've provided the two files I use for the colors and the bash resources along with a screenshot, so you can check whether this is for you.


Standart ist der Standardfehler
open | download - DIR_COLORS (2.2 KB)
open | download - bash.bashrc (5.7 KB)
open | download - logo_login.png (86.6 KB)
Re: Beauty and the Beast - any beast IN (Dockstar, GoGlex Net/Home, Pogo E02, ...) is ok
March 06, 2013 04:56PM
Very nice :) Thanks for sharing!
Not sure what I am doing wrong, but the "--->" doesn't get displayed. Check the attached screenshot.
open | download - debian-colors.PNG (45.1 KB)
Just an idea: could it be the keyboard layout? Also, I noticed that the background of the logo in your case is solid black while in my case it is a dark gray. What happens after a reboot? Other than that: no idea, sorry.

Standart ist der Standardfehler

Edited 1 time(s). Last edit at 03/12/2013 03:16AM by chessplayer.

I bet you use putty to access to your device. Apparently putty does not support the code for characters used for the "-->".

I sees the arrow when I access my device via ssh from another Linux machine but see what you saw if I access the same device from putty.
Hi guys,

this, however, is also strange. If you look at the picture in the post by Obihörnchen, it sure looks like he also uses putty. On the other hand, the bash.bashrc for the Archlinux case does not include calling something like linuxlogo, so maybe that messes things up for putty?

But then again, who wants to use M$-OSes on their main computer anyway?



Standart ist der Standardfehler
Re: Beauty and the Beast - any beast IN (Dockstar, GoGlex Net/Home, Pogo E02, ...) is ok
March 12, 2013 09:36AM
That would be caused by font which may be set by the locale.
Re: Beauty and the Beast - any beast IN (Dockstar, GoGlex Net/Home, Pogo E02, ...) is ok
October 17, 2013 01:03AM
It was the character encoding setting in putty. Changed it to UTF and everything displayed correctly.


Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.