No more ssh enable checkbox in
November 09, 2010 10:50PM
I just bought a dockstar and try to follow the step in this website. The only issue is that I can not ssh into my dockstar before activation. So I acativate and registered an account on However, I still did not find the enable ssh check box in the security setting page. Am I missing something or the website take that option off? Can anyone help me on this? Many thanks.
Re: No more ssh enable checkbox in
November 10, 2010 11:06PM
Problem solved, just check all the check box available on the webpage and now I can ssh into my dockstar. However, I did not have luck to boot into the debian I installed on my micro-SD card put into a usb card reader.
I'm having similar issues on my Dockstar.... I had debian setup from the USB stick and it was booting fine, although my Samba shares weren't setup properly. I renabled Pogo services in /etc/init.d/rcS to gain temporary access to Samba. SSH was working fine at this time for about a week and then all of a sudden, the map drive was not showing up on my Windows 7 laptop. Funny thing was iTunes was still able to see my music collection at this time on the same laptop.

Anyway, I tried to to open the samba share using Dockstar's IP address and Widows was complaing about a security inconsistency in its internal LSA database. Thinking there is an issue with the Samba setup (between Debian and Cloud), I disabled Pogo again through SSH. When I rebooted my Dockstar, I lost SSH, but apparently I'm still able to log into My Pogo, but it says no drive is connected, so it looks like the Dockstar is not talking to Pogo Services either. I even tried rebooting Dockstar with just the USB key (no HDD attached). Not sure if my USB stick just when bad, will try a different stick, but in the meantime, are there any suggestions that I can try?

I forgot to add, the Dockstar shows up on the DHCP Client list on the router (same IP address as ever), I can ping the device and SSH says 'Network connection refused'. So it appears to be booting up fine, although I'm not sure if it is from the internal NAND or from the USB stick.
Re: No more ssh enable checkbox in
November 18, 2010 03:18PM
I'm no expert (my DockStar hasn't even arrived yet) but I have read a fair bit about this in the last two days.

If you have re-enabled hbwd, it may have downloaded and flashed the updated firmware which disables ssh by default. You should be able to re-enable ssh on the pogoplug site if this is the cause of your problem.
Thanks, Lotus49. There are two issues to implement your suggestion...
1. Like the subject of this thread mentions, the Pogoplug website doesn't offer you an option to enable SSH
2. Perhaps the bigger issue is I disabled the hbwd before I lost SSH - my Dockstar can't talk to Pogo website anymore.
Re: No more ssh enable checkbox in
December 09, 2010 01:06AM
did u ever find a resolution to this? I have the same problem
Re: No more ssh enable checkbox in
December 09, 2010 09:02AM
Ravi Wrote:
> 1. Like the subject of this thread mentions, the
> Pogoplug website doesn't offer you an option to
> enable SSH

The Pogoplug website has the option to enable SSH. Just check the image below.

Edited 1 time(s). Last edit at 12/09/2010 09:02AM by varkey.
open | download - pogo_ssh.JPG (32.6 KB)
I dont have that option on eather can some one help ? What did I do wrong ?
yozh Wrote:
> I dont have that option on eather
> can some one help ? What did I do wrong ?

any news on this, i have the same problem. cant connect via ssh- and theres no checkbox in

Plz give advice.
I had the same problem with a pink pogoplug. I could not get the "Enable SSH" checkbox.
After contacting pogoplug support, It turned out to be a firewall issue:
Make sure that UDP port 4365 from the WAN is redirected to the pogoplug.

In my router, I added a port forwarding rule from WAN port 4365 to the pogoplug port 4365 (you would probably need to give your pogoplug a known ip address -- I did this by asking the DHCP server on the router to always give the pogoplug the same ip address based on the pogoplug's MAC address)

Immediately I was able to turn SSH on, and I'm currently upgrading to debian sid.

Jeff - Thank you for the simplest debian install I ever did (and I did many ...)

Re: No more ssh enable checkbox in
February 26, 2011 08:40PM
I have a question: one of my dockstar's firmware was automatically updated and I have enabled the ssh through I am using optware on it. With the updated firmware, is it safe to install the debian as the instruction by Jeff? I have another dockstar with debian and this one works very well, that is why I would like to have the first one to have debian too. But I am not sure if it is safe with the new firmware. Thanks.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.