Welcome! Log In Create A New Profile


Dockstar bricked? :(

Posted by senor 
Dockstar bricked? :(
December 07, 2010 05:30PM
hey there,

due to a failing usb stick I replaced my dockstar installation today. As I was still running one of the oldest jeff-scripts, I took "the chance" to update to the latest kernel (http://forum.doozan.com/read.php?2,582,582) and in one step (so without reboot of the Dockstar) the rescue system (http://forum.doozan.com/read.php?4,831). now my Dockstar keeps flashing the green LED, then the LED switches off and I can't access my debian installation by ssh. the same for the "rescue" system :(
Any idea how I can un-brick my Dockstar without a cable, as I don't have one and I don't know where to get it?


bye, michael
Re: Dockstar bricked? :(
December 07, 2010 11:09PM
I cant help you out with a no cable approach but, the cable you would need to start out with would be a Nokia CA-42 USB. http://www.amazon.com/Cable-Nokia-CA-42-Wireless-Accessory/dp/B000BI4HW8. And here is a site that shows a neat setup with for it http://www.yourwarrantyisvoid.com/2010/07/21/seagate-dockstar-add-an-accessible-serial-port/. I havent actually had to deal with your situation. But if needed there are instructions on how to setup jtag on that blog. hope this helps
Re: Dockstar bricked? :(
December 07, 2010 11:20PM
The same CA-42 cable, sold for a different model Nokia phone, is a couple bucks cheaper here, and from the same vendor. (Go figure!)

Can anyone tell me the pinouts on the Nokia end of the cable, so I can tell which wire serves which function without having to resort to opening up the USB end to check?
Re: Dockstar bricked? :(
December 08, 2010 04:18AM
okay, thanks for the cable, ordered :) anyone have an idea if it is possible to undo the kernelupgrade on the USB stick (deleting some files or so)? Or is it possible to execute jeffs debian script on a normal linux machine in order to get a plain, working USB stick installation?

bye, michael
Re: Dockstar bricked? :(
December 08, 2010 02:15PM
restamp Wrote:
> Can anyone tell me the pinouts on the Nokia end of
> the cable, so I can tell which wire serves which
> function without having to resort to opening up
> the USB end to check?

I don't know the pinout of the Nokia connector. Here's how I determined the wiring of mine (different source -- on eBay -- so you'll have to check your own):
  1. Cut off the Nokia connector and strip the ends of the 4 wires.
  2. Plug the USB end into your computer and start a terminal emulator / comm program on the corresponding serial port.
  3. Use a multimeter to determine which wires are ground and V+.
  4. Type characters in the comm program while using a multimeter or speaker/buzzer to determine which wire is TX.
  5. Conclude that the remaining wire is RX. If you connect it to TX, the characters you type in the comm program should be echoed.

You only need to connect TX, RX, and GND to the DockStar; ignore the V+ wire.
Re: Dockstar bricked? :(
December 08, 2010 03:20PM
Thanks, ecc, I think that will work for me!
Re: Dockstar bricked? :(
December 08, 2010 04:51PM
I'm not sure what you are saying exactly.
Can you boot from usb stick?
If your bootloader still works, you might be able to download an image that would work and you would at least have usb stick access.
I'm gonna give you a website, where you could get a ready made image for dockstar, you have to follow the guide and it will create bootable dockstar debian squeeze install.

Once you boot from usb stick, you can reflash bootloader and load recovery system back on.

I'm trying to get Jeff and the guys to come up with a Recovery Nand program, so we could fix this stuff, provided you have usb stick boot, to load back on factory Nand, or other people's working NAND.

download the squeezeplug dockstar image here:

download the usb image tool here:

here is the wiki instructions , just start looking at the guide for dockstar image instructions:

Thing is we don't know if your bootloader is still intact, and if you don't have a working image, the method I'm telling you about here, would create that image without having to make it using Jeff's install method. If you can't boot usb drive, yeah, you would need cat 42. Worth a try.

Edited 3 time(s). Last edit at 12/08/2010 04:57PM by rgtaa.
Re: Dockstar bricked? :(
December 09, 2010 09:45AM
hey, sorry if I was not clear enough ;) my dockstar was running for months (with the original pogoplug software on nand and debian on an usb stick), therefore I was not changing anything (like kernel update). recently, my old USB stick died, so I bought a new stick and installed it with jeffs script, logged in (so the vanilla debian installation worked well on the new stick) and "went all the way" ;) (samba, newest kernel update and - without a reboot - the rescue system on nand). after this procedure, I rebooted the dockstar, but it was just flashing the green LED rapidly and after 10s the LED turned off; no ping or ssh answer.

BUT: I just tried rgtaa's method with the image and...it works again! :) so, I don't have a clue why the dockstar can boot a vanilla debian installation but not boot the rescue system on nand or the kernel-updated version on my usb stick. maybe this can be fixed someday :)

bye, michael
Re: Dockstar bricked? :(
December 09, 2010 10:10AM
Glad that worked for you.

From usb stick, do the recovery system install.

Edited 1 time(s). Last edit at 12/09/2010 10:13AM by rgtaa.
Re: Dockstar bricked? :(
December 09, 2010 11:06AM
okay, installed the rescue system to nand again, but it is still not reachable after reboot (green LED flashing, orange LED flashing, LED off). some people report in this forum, that the arcnumber may lead to a non-booting rescue system, maybe this is my problem? but how can I change the arcnumber of the rescuesystem, if I can't get access to it :(
Peter Hope-Tindall
Re: Dockstar bricked? :(
December 09, 2010 11:10AM
If you can book to a USB stick - you can use fw_setenv arcNumber 2097 to set it back.

You can also use netconsole or serial cable to change the environment value using uboot

(interrupt the book and use setenv to change the value).

Re: Dockstar bricked? :(
December 09, 2010 11:32AM
thanks, that’s it! :) setting the arcnumber to 2097 solved the non-bootable rescue system problem :)
Re: Dockstar bricked? :(
December 09, 2010 02:00PM
I have a tonidoplug that doesn't work from NAND , I was wondering if there is a way to remove arcNumber stuff completely. Not sure if that would fix the problem.

I can boot from usb stick and I can boot from recovery system on it, but I am able to flash the tonidoplug back to factory but not sure if arcNumber stuff would screw up the tonidoplug from seeing NAND factory install.
Re: Dockstar bricked? :(
February 08, 2011 01:53PM
I cant access the uboot anymore, someone today unplugged my dockstar, i think the debian is also corupted, is there anyway to install debian on the usb without the dockstar??

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.