Welcome! Log In Create A New Profile

Advanced

Help with iomega ix4-200d installation

Posted by TrashCanMan 
TrashCanMan
Re: Help with iomega ix4-200d installation
January 12, 2020 05:44AM
bodhi Wrote:
-------------------------------------------------------
> TrashCanMan ,
>
> In the
> WIki
> thread
:
>
>
Quote

Debian Stretch and OpenMediaVault (OMV4) on
> Netgear Stora
>
>
Quote

Thanks to information found mainly here
> (but also a little found elsewhere), I have made
> my Stora into an Open Media Vault. Note that the
> current release of OMV, OMV4, is NOT supported on
> Buster and does not install. You must install
> Stretch
>
> So your OMV problem is just that. Many users have
> tried Debian buster and it did not work. All have
> reported that Debian stretch is the right version
> to use.
>

OFC i know all that i did my research, i did the procedure exactly like that "omv on stora" thread (exept that i didnt move the installation to hdd), if you look his thread i even suggested a tiny but "capital" correction to his instructions a few days ago...


> Debian stretch rootfs:
>
> https://forum.doozan.com/read.php?2,12096,12098#msg-12098
>
>
Quote

> Updated 24 Jul 2017:
>
> Basic Debian stretch Kirkwood rootfs for most
> Kirwood plugs:
>
> - tarball size: 188M
> - install size: 488M
> - The init system used in this rootfs is sysvinit
> . To boot with systemd, see note 2 below.
> - Installed packages: nano, avahi, ntp,
> busybox-syslogd (log to RAM), htop,
> isc-dhcp-client, dialog, bzip2, nfs server/client,
> iperf, ethtool, sysvinit-core, sysvinit, and
> sysvinit-utils.
> - see LED controls in /etc/rc.local, and
> /etc/init.d/halt
> - see some useful aliases in /root/.profile
> - root password: root
>
> Download at Dropbox:
>
> Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi.tar.bz2
>
>
> You can upgrade the kernel to the latest version
> after booting
> Debian-4.12.1-kirkwood-tld-1-rootfs-bodhi.tar.bz2.
Re: Help with iomega ix4-200d installation
January 12, 2020 06:43PM
@bodhi Sorry to bother you one last time, how can i go back to uboot stock envs?

Stock envs:
Marvell>> printenv
bootdelay=1
baudrate=115200
loads_echo=0
ipaddr=10.4.50.165
serverip=10.4.50.5
rootpath=/mnt/ARM_FS/
netmask=255.255.255.0
run_diag=yes
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_root=root=/dev/nfs rw
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
console=console=ttyS0,115200 mtdparts=nand_mtd:0xa0000@0x0(uboot),0x00010000@0x000a0000(param),32m@0x0(flash)
uboot_start=0x0
uboot_size=0xa0000
env_start=0xa0000
env_size=0x10000
kernel_start=0xb0000
kernel_size=0x228000
initrd_size=0x300000
make_boot_args=setenv bootargs console=ttyS0,115200 mtdparts=nand_mtd:$(uboot_size)@$(uboot_start)(uboot),$(env_size)@$(env_start)(env),$(kernel_size)@$(kernel_start)(zImage),$(initrd_size)@$(initrd_start)(initrd),32m@0x0(flash);
flash_load=run make_boot_args;nand read.e 0x2000000 $(kernel_start) $(kernel_size);nand read.e 0x12000000 $(initrd_start) $(initrd_size);bootm 0x2000000 0x12000000;
bootcmd=run flash_load;
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end); bootm 0x2000000;
ethmtu=1500
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
uboot_ver=v1.1.1
ethact=egiga0
mfgmodel=ix4
fw_ver=v1_0_11_3114995
preroot_ver=0.1.5
serial_number=5560Y01011G20100292J0J1
ethaddr=00:D0:B8:1F:50:89
serialNo=USC010GSA1
modelname=31962501
serialno=0,0118gBxqcDGGeguzOfdnxDWIlC5ZgYwIbHDMYf+jxSXdjJcBN5EYWlzzPx4UCzchQT,USC010GSA1,
runintime=10800
ftpserver=192.168.16.4
testfile=4NC
mfgtest_state=system_tested_ok
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=no
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
initrd_start=0x2d8000
disaMvPnp=no
eth1addr=00:d0:b8:1f:50:8a
enaAutoRecovery=yes
pcieTune=no

Environment size: 1931/16380 bytes
Marvell>>



Envs now:
Marvell>> printenv
bootdelay=1
baudrate=115200
loads_echo=0
ipaddr=10.4.50.165
serverip=10.4.50.5
rootpath=/mnt/ARM_FS/
netmask=255.255.255.0
run_diag=yes
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_root=root=/dev/nfs rw
bootargs_end=:::DB88FXX81:eth0:none
image_name=uImage
console=console=ttyS0,115200 mtdparts=nand_mtd:0xa0000@0x0(uboot),0x00010000@0x000a0000(param),32m@0x0(flash)
uboot_start=0x0
uboot_size=0xa0000
env_start=0xa0000
env_size=0x10000
kernel_start=0xb0000
kernel_size=0x228000
initrd_size=0x300000
make_boot_args=setenv bootargs console=ttyS0,115200 mtdparts=nand_mtd:$(uboot_size)@$(uboot_start)(uboot),$(env_size)@$(env_start)(env),$(kernel_size)@$(kernel_start)(zImage),$(initrd_size)@$(initrd_start)(initrd),32m@0x0(flash);
flash_load=run make_boot_args;nand read.e 0x2000000 $(kernel_start) $(kernel_size);nand read.e 0x12000000 $(initrd_start) $(initrd_size);bootm 0x2000000 0x12000000;
standalone=fsload 0x2000000 $(image_name);setenv bootargs $(console) root=/dev/mtdblock0 rw ip=$(ipaddr):$(serverip)$(bootargs_end); bootm 0x2000000;
ethmtu=1500
mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500
usb0Mode=host
nandEcc=1bit
netretry=no
rcvrip=169.254.100.100
loadaddr=0x02000000
autoload=no
uboot_ver=v1.1.1
ethact=egiga0
mfgmodel=ix4
fw_ver=v1_0_11_3114995
preroot_ver=0.1.5
serial_number=5560Y01011G20100292J0J1
ethaddr=00:D0:B8:1F:50:89
serialNo=USC010GSA1
modelname=31962501
serialno=0,0118gBxqcDGGeguzOfdnxDWIlC5ZgYwIbHDMYf+jxSXdjJcBN5EYWlzzPx4UCzchQT,USC010GSA1,
runintime=10800
ftpserver=192.168.16.4
testfile=4NC
mfgtest_state=system_tested_ok
load_initrd=ext2load usb 0:1 0x2100000 /boot/uInitrd
load_uimage=ext2load usb 0:1 0x800000 /boot/uImage
usb_boot=usb start; run load_uimage; run load_initrd; bootm 0x800000 0x2100000
bootcmd=run usb_make_boot_args ; run usb_boot; reset
usb_make_boot_args=setenv bootargs console=ttyS0,115200 mtdparts=orion_nand:$(uboot_size)@$(uboot_start)(uboot),$(env_size)@$(env_start)(env),$(kernel_size)@$(kernel_start)(zImage),$(initrd_size)@$(initrd_start)(initrd),32m@0x0(flash) root=LABEL=rootfs rootdelay=10 earlyprintk=serial init=/bin/systemd
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=no
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
initrd_start=0x2d8000
disaMvPnp=no
eth1addr=00:d0:b8:1f:50:8a
enaAutoRecovery=yes
pcieTune=no

Environment size: 2446/16380 bytes
Marvell>>

Re: Help with iomega ix4-200d installation
January 12, 2020 10:31PM
TrashCanMan,

In serial console:
setenv bootcmd 'run flash_load'

And then try booting
boot

After you've verified that it boot successfully to stock, reboot and interrupt serial console,

setenv bootcmd 'run flash_load'
saveenv

From now on, it always boots to stock.

To test Debian booting again, interrupt serial console and

setenv bootcmd 'run usb_make_boot_args ; run usb_boot; reset'
boot

Note: just recycle power, or reboot while in Debian would boot it back to stock again, like nothing changed.

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: