Welcome! Log In Create A New Profile

Advanced

Help unbricking Synology DS411Slim

Posted by rclsilver 
Help unbricking Synology DS411Slim
May 21, 2022 08:06AM
Hi,

My father's synology DS411Slim is bricked: blinking blue light without any data on the console serial port (J1). I replaced the board battery and tried with an other power supply.

I guess data on the flash (ST M25P32) are corrupted. I used a TL866II-Plus to read existing data (here is the dump: backup.img).

At this point, I analyzed the dump and found header of rd.bin and zImage files (found from .pat file).

Someone know how to found or build a working image to write to the flash?

Thanks for your help!
Re: Help unbricking Synology DS411Slim
May 21, 2022 03:39PM
rclsilver,

blinking blue light without any data on the console serial port (J1).

Sounds like u-boot was corrupted. The kernel files rd.bin and zImage on flash might still be OK (but we'll know one way or the other, when you get to that point where you can see u-boot running).

You can try to boot with UART using kwboot. See this post:

https://forum.doozan.com/read.php?3,51739,51919#msg-51919

Download the tarballs for the following u-boots from the release thread:

uboot.2017.07-tld-1.iconnect.mtd0.kwb
uboot.2017.07-tld-1.pogo_e02.mtd0.kwb
uboot.2017.07-tld-1.nsa325.mtd0.kwb

And try booting with kwboot (running on another Linux box, where the serial module converter is).

Try each u-boot image above to see which one will boot and get you to the u-boot count down. If you can get to the cound down, then find the stock u-boot image for this box somewhere, and then you can flash it in serial console.

Also, if you can find stock u-boot image, then it can be used to run with kwboot, too.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 05/21/2022 03:43PM by bodhi.
Re: Help unbricking Synology DS411Slim
May 22, 2022 01:41AM
Hi,

After several tries, the behavior of the card has changed: now the green LED is blinking very fast and I can hear a tick-tick-tick...

I guess the card is definitely dead. What do you think?
Re: Help unbricking Synology DS411Slim
May 22, 2022 03:39PM
> After several tries,

Several kwboot tries?

> the behavior of the card has
> changed: now the green LED is blinking very fast
> and I can hear a tick-tick-tick...

There is alway some hope of reviving the box if the LED is still blinking. If it is off and the board is silent then it is really dead.

And did the serial console work (you've connected and see output) before the box was bricked?

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Help unbricking Synology DS411Slim
May 23, 2022 03:52PM
> > After several tries,
>
> Several kwboot tries?
>

Yes, after some tries, board did blue blink but instead I heard a tick-tick-tick with a green LED flashing very fast (I tried to record it: https://youtube.com/shorts/Db1kDUckKbw). Maybe a component has died? Capacitor?

>
> And did the serial console work (you've connected
> and see output) before the box was bricked?
>

The box was in my parent's house before it was bricked. Since my father bring it to me, I never seen nothing on the serial output. I was so close to build a u-boot image that I could flash to the eeprom, but with the new behavior, I guess i have to fix something before :'(
Re: Help unbricking Synology DS411Slim
May 23, 2022 05:53PM
> The box was in my parent's house before it was
> bricked. Since my father bring it to me, I never
> seen nothing on the serial output.

That's what I was thinking. If this is the first time you connect the serial console to this box, then perhaps the connection is not good. Try checking the wires, swapping TX and RX.

It is always better to have a connected serial console and see normal output, and can interrupt u-boot.... before we need it.

Usually, the LED blinking is from u-boot. Very few boxes have this blinking on its own. So the best scenario is that u-boot has started and got stuck somewhere.

-bodhi
===========================
Forum Wiki
bodhi's corner
Re: Help unbricking Synology DS411Slim
May 24, 2022 08:06AM
Hi,

Since the LED is flashing green very fast, I can get some output on the serial port. I created a dump (ttyS0.log).

I'm using a TTL <> USB:
USB GND => J1 Pin 2
USB RX => J1 Pin 4
USB TX => J1 Pin 6

I erased the eeprom and I've the same behavior: green led flashing very fast. If I connect 3.3V to J1 Pin 1, LED isn't flashing anymore, it's always ON.
Attachments:
open | download - ttyS0.log (243.7 KB)
Re: Help unbricking Synology DS411Slim
May 24, 2022 03:29PM
Not sure about this behavior. But the 3.3V should not be connected. You could fry the serial port with the power connected to it. The power should come from the USB converter only.

But there are garbage chars output to the log, so it was likely not damage. How about: restore the eeprom, connect serial console without the 3.3.V, just 3 wires and try:

- swapping TXD and RXD

- If you have the stock bootlog you might see what speed the serial port should be used. For example, a typical baud rate is 115200

picocom --b 115200 --f n --p n --d 8 /dev/ttyUSB0

Some boxes use different baud rate for serial console (very few do this). But kwboot always uses 115200 because it communicates with the BootROM using this fixed baud rate.

Also, I'm not familiar with this box, so not sure if the serial pinouts you've posted is correct or not.

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: