Welcome! Log In Create A New Profile


PogoV4-A3-01 troubles

Posted by kraqh3d 
PogoV4-A3-01 troubles
January 22, 2014 01:15AM
I need some ideas. It's very late. I'm probably missing something trivial and its driving me crazy.

I got this Pogo just a little while ago so it's my newest toy. Over the weekend I got it booting Debian off USB using the Arch ALARM uboot. I had ran a revert to play around with using my.pogoplug.com to backup over the Internet. For giggles. I was curious about throughput. Today I fix the bootcmd and now it refuses to boot off USB. I connect back up via serial and the error I get is that the ALARM uboot isn't recognizing the ext3 partition. The stick boots fine in a Dockstar and in an NSA320. The error is below along with usb part output.

** Invalid partition type "X�c" (expect "U-Boot")

ALARM>> usb part
print_part of 0

Partition Map for USB device 0  --   Partition Type: DOS

Partition     Start Sector     Num Sectors     Type
    1                    0         2023424      f8

print_part of 1
## Unknown partition table

print_part of 2
## Unknown partition table

print_part of 3
## Unknown partition table

print_part of 4
## Unknown partition table

I restore a near virgin backup copy of bohdi's kirkwood 3.12.0 rootfs to it. (Near virgin. I added a few utils to it before making the image backup -- mtdutils, usbutils, pciutils, sudo, I forget what else but a few other things.) It won't boot and I get the same error that the partition is unrecognized. I again validate it boots in the Dockstar. I get Debian running using tftp to load uImage and uInitrd and bootm with the rootfs on the stick with no problem. (root=LABEL=ROOTFS)

I restore the image to a different stick. I make sure it boots it on the Dockstar. It won't boot on the PogoV4. Same error. I again tftp boot using the stick as rootfs and its fine.

Finally I recall that I used a really old 128M stick for the revert. I find it. It's FAT. I place both uImage and uInitrd on it and manually fatload them. There's no problem with that. I swap sticks with the original and bootm and it comes up.

I can't figure out why uboot doesn't like the partition on the other sticks. I only run Linux at home. My backup was from a stick that I formatted fresh with mkfs and then untar'ed the rootfs onto. It's really late now. I can't think anymore. I'm going to totally reformat a stick tomorrow and untar the rootfs onto it instead of dd restoring the image backup.

If anyone has any ideas, please shout them out. This is driving me crazy. The box is running but its annoying. I've been trying to get a single stick image that'll work on all my devices. This should be it (excluding my Stora) if I could get it to boot!
Re: PogoV4-A3-01 troubles
January 22, 2014 03:46AM

Check your uBoot envs, must be some changes you've made? I'm using the same Ext3 rootfs for all these boxes, including the Pogo V4. The symptom does indicate it could be either uBoot envs or messed up rootfs partition. I would try booting with my original rootfs untarred to a newly formatted Ext3 USB stick first.

Forum Wiki
bodhi's corner (buy bodhi a beer)
Re: PogoV4-A3-01 troubles
January 22, 2014 10:36AM
Nope. Nothing at all wrong with the environment variables. I dd'ed wacked the first 512 bytes of the same stick to effectively blank the partition table. I ran back thru fdisk and mkfs again. Untar'ed your rootfs to it. And it boots with no other changes at all. The ALARM uboot doesn't complain about it and its properly reporting partition type 83 as it should. It's running right now. I rebooted it like 5 times. LOL.

This made me think about what did I do in between and I think I know what. I was using too small of a stick to start with. It was good enough to boot but thats it. I used dd to image it (the entire disk, not the partition) and then restored that image to the stick I'm using now. I then used gparted to expand the partition. I pretty much never use gparted, except to expand partitions because its a pain in the ass do that manually. It must've done something to the partition table that the ALARM uboot doesn't like. of course I didnt keep the smaller image. I only kept the image after resizing it and installing some more packages.

I don't know where it got that the partition type was F8. The davygravy uboots had no problem with the stick or any of the clones I made from the original dd image last night. And I know for a fact that my linux desktop always said the partition type was 83 in fdisk because I kept checking. I have to play with this more. This is annoying.

Edited 5 time(s). Last edit at 01/22/2014 10:42AM by kraqh3d.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.