Welcome! Log In Create A New Profile


Boot Problems Pogoplug E02

Posted by mofeywalker 
Boot Problems Pogoplug E02
March 24, 2014 06:01AM
Hello guys,

I have run into a problem with my Pogoplug. Until yesterday I was running the Arch Linux build which worked perfectly for me. But yesterday I tried to reboot and now I can't ssh into my system anymore.
So I started to reinstall Arch with these instructions: http://archlinuxarm.org/platforms/armv5/pogoplug-v2-pinkgray.
The installation works flawlessly but after "/sbin/reboot/" I am not able to get a ping from the Pogoplug.

I also activated netconsole and it gives me the following output:

U-Boot 2011.12 (Feb 20 2012 - 21:21:59)
Pogoplug E02
arm-none-linux-gnueabi-gcc (Sourcery G++ Lite 2009q3-67) 4.4.1
GNU ld (Sourcery G++ Lite 2009q3-67)
Hit any key to stop autoboot:  0
(Re)start USB...
USB:   Register 10011 NbrPorts 1
scanning bus for devices... 3 USB Device(s) found
       scanning bus for storage devices... 1 Storage Device(s) found
Loading file "/rescueme" from usb device 0:1 (usbda1)
** File not found /rescueme
reading /rescueme.txt

** Unable to read "/rescueme.txt" from usb 0:1 **
Creating 1 MTD partitions on "nand0":
0x000002500000-0x000008000000 : "mtd=3"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    129024 bytes
UBI: smallest flash I/O unit:    2048
UBI: sub-page size:              512
UBI: VID header offset:          512 (aligned 512)
UBI: data offset:                2048
UBI: fixable bit-flip detected at PEB 77
UBI: attached mtd1 to ubi0
UBI: MTD device name:            "mtd=3"
UBI: MTD device size:            91 MiB
UBI: number of good PEBs:        728
UBI: number of bad PEBs:         0
UBI: max. allowed volumes:       128
UBI: wear-leveling threshold:    4096
UBI: number of internal volumes: 1
UBI: number of user volumes:     0
UBI: available PEBs:             717
UBI: total number of reserved PEBs: 11
UBI: number of PEBs reserved for bad PEB handling: 7
UBI: max/mean erase counter: 1/1
UBIFS error (pid 0): ubifs_get_sb: cannot open "ubi:rootfs", error -19
Error reading superblock on volume 'ubi:rootfs'!
Loading file "/boot/uImage" from usb device 0:1 (usbda1)
1 bytes read
Found bootable drive on usb 0:1
Loading file "/boot/uImage" from usb device 0:1 (usbda1)
3148740 bytes read
Loading file "/boot/uInitrd" from usb device 0:1 (usbda1)
** File not found /boot/uInitrd
## Booting kernel from Legacy Image at 00800000 ...
   Image Name:   Linux-3.1.10-32-ARCH
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3148676 Bytes = 3 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK

Starting kernel ...

Is this the problem? And when yes, how do I resolve it?

UBIFS error (pid 0): ubifs_get_sb: cannot open "ubi:rootfs", error -19
Error reading superblock on volume 'ubi:rootfs'!

Thank you for reading.

Best regards
Re: Boot Problems Pogoplug E02
April 01, 2014 03:23PM
have exactly the same problems after installing the new uboot from http://archlinuxarm.org/platforms/armv5/pogoplug-v2-pinkgray.
My pogoplug is halting after 'Starting Kernel...', no dmesg-ish output whatsoever.
I read more people with this problem:

* some of them got it after upgrading their kernel (chrooted and down/upgraded with older/bugfixed version)

However, Im not one of them, I simply ran the uboot installerscript, which doesnt seem to load my kernel properly anymore.
I have the feeling as if some uboot fw_setenv-settings are missing, to get a rootfs going.
Im hoping to solve this one without serial cable.

Any help appreciated.
Coder of Salvation
Re: Boot Problems Pogoplug E02
April 01, 2014 05:46PM
ok, I decided to give up..
Usually that is a good thing, because it opens new doors.
I decided to try flash my pogoplug e02 with the latest uboot, which did not boot the original pogoOS *and* my old archlinux.
So..I officially messed things up :)

So..in a moment of despair, I decided to give debian squeeze another go (Tried it before, did not work).
Anyways, I got debian squeeze working right now with this link:


^--- that is exactly how it went. With my latest uboot installed, I untarred it to a new usbdisk.
Now I will migrate my old archlinux usbdisk step by step to debian squeeze.
Im gonna backup all my installationfiles + tutorial, and never touch uboot again..Im getting too old for these kind of surprises :D

IMPORTANT: all of you who are experiencing 'Starting kernel ...' being the last netconsole message: THIS IS NORMAL.
It doesnt have to mean anything (which I thought for a while).
When I could login to my debian squeeze box, I realized that it stopped outputting anything after 'Starting Kernel ...', so I guess people with the
serial console have more output compared to networked netconsole. Or my uboot settings are corrupt..who knows.

hope this helps anyone
Re: Boot Problems Pogoplug E02
April 01, 2014 05:50PM
You can interrupt netconsole, and execute
post the out put here, and we'll take a look if anything missing!

Forum Wiki
bodhi's corner (buy bodhi a beer)
Re: Boot Problems Pogoplug E02
April 06, 2014 03:27PM
Hey guys,

thank you very much for the answers. I managed to install debian with the instructions from bodhis thread and could finally ssh into my pogo.
Now I use debian instead of arch :)


Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.