Welcome! Log In Create A New Profile

Advanced

Not the correct encoding?

Posted by rkrug 
Not the correct encoding?
December 30, 2017 10:08AM
Hi

I an using a CP2102 USB to UART bridge, and it connects correctly.

I am using "serial" on my mac, but something is wrong with the encoding (?) as I get the following:

U-B⎺⎺├ 2011.12 (F␊␉ 20 2012 - 21:21:59)
P⎺±⎺⎻┌┤± E02

S⎺C:   K␋⎼┐┬⎺⎺␍ 88F6281_A0
DRAM:  256 M␋B
WARNING: C▒␌␤␊⎽ ┼⎺├ ␊┼▒␉┌␊␍
NAND:  128 M␋B
I┼:    ⎽␊⎼␋▒┌
O┤├:   ⎽␊⎼␋▒┌
E⎼⎼:   ⎽␊⎼␋▒┌
N␊├:   ␊±␋±▒0
88E1116 I┼␋├␋▒┌␋≥␊␍ ⎺┼ ␊±␋±▒0
H␋├ ▒┼≤ ┐␊≤ ├⎺ ⎽├⎺⎻ ▒┤├⎺␉⎺⎺├:  0 
(R␊)⎽├▒⎼├ USB...
USB:   R␊±␋⎽├␊⎼ 10011 N␉⎼P⎺⎼├⎽ 1
USB EHCI 1.00
⎽␌▒┼┼␋┼± ␉┤⎽ °⎺⎼ ␍␊┴␋␌␊⎽... 3 USB D␊┴␋␌␊(⎽) °⎺┤┼␍
       ⎽␌▒┼┼␋┼± ␉┤⎽ °⎺⎼ ⎽├⎺⎼▒±␊ ␍␊┴␋␌␊⎽... 1 S├⎺⎼▒±␊ D␊┴␋␌␊(⎽) °⎺┤┼␍
L⎺▒␍␋┼± °␋┌␊ "/⎼␊⎽␌┤␊└␊" °⎼⎺└ ┤⎽␉ ␍␊┴␋␌␊ 0:1 (┤⎽␉␍▒1)
** F␋┌␊ ┼⎺├ °⎺┤┼␍ /⎼␊⎽␌┤␊└␊
⎼␊▒␍␋┼± /⎼␊⎽␌┤␊└␊.├│├

** U┼▒␉┌␊ ├⎺ ⎼␊▒␍ "/⎼␊⎽␌┤␊└␊.├│├" °⎼⎺└ ┤⎽␉ 0:1 **
C⎼␊▒├␋┼± 1 MTD ⎻▒⎼├␋├␋⎺┼⎽ ⎺┼ "┼▒┼␍0":
0│000002500000-0│000008000000 : "└├␍=3"

[    0.000000] I┼␋├␋▒┌␋≥␋┼± ␌±⎼⎺┤⎻ ⎽┤␉⎽≤⎽ ␌⎻┤⎽␊├
[    0.000000] I┼␋├␋▒┌␋≥␋┼± ␌±⎼⎺┤⎻ ⎽┤␉⎽≤⎽ ␌⎻┤
[    0.000000] L␋┼┤│ ┴␊⎼⎽␋⎺┼ 2.6.32.18-␍⎺␌┐⎽├▒⎼ (⎼⎺⎺├@⎽├°┤.├␌␉┼␊├) (±␌␌ ┴␊⎼⎽␋⎺┼ 4.3.5 (B┤␋┌␍⎼⎺⎺├ 2010.08) ) #1 T␤┤ F␊␉ 17 03:09:57 EST 2011
[    0.000000] CPU: F␊⎼⎺␌␊⎺┼ 88FR131 [56251311] ⎼␊┴␋⎽␋⎺┼ 1 (ARM┴5TE), ␌⎼=00053977
[    0.000000] CPU: VIVT ␍▒├▒ ␌▒␌␤␊, VIVT ␋┼⎽├⎼┤␌├␋⎺┼ ␌▒␌␤␊
[    0.000000] M▒␌␤␋┼␊: M▒⎼┴␊┌┌ S␤␊␊┴▒P┌┤± R␊°␊⎼␊┼␌␊ B⎺▒⎼␍
[    0.000000] M␊└⎺⎼≤ ⎻⎺┌␋␌≤: ECC ␍␋⎽▒␉┌␊␍, D▒├▒ ␌▒␌␤␊ ┬⎼␋├␊␉▒␌┐


So some characters are not correct. The Baudrate is set to 115200, 8 data bits, no parity, 1 stop bit.

Terminal emulation xterm, text encoding UTF-8.

Any ideas?

Rainer

===========================
Blog: https://rmkrug.wordpress.com/

1 x Pogoplug E02 (pink): Logitech media server

1 x Pogoplug E02 (pink): FTP server only (throw away configuration - quick to rebuild)

1 x GoFlex Net: running OpenMediaVault
Re: Not the correct encoding?
December 30, 2017 10:15AM
OK - got it working.

Changed Terminal Emulation to NONE.

Cheers,

Rainer

===========================
Blog: https://rmkrug.wordpress.com/

1 x Pogoplug E02 (pink): Logitech media server

1 x Pogoplug E02 (pink): FTP server only (throw away configuration - quick to rebuild)

1 x GoFlex Net: running OpenMediaVault
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: