Welcome! Log In Create A New Profile

Advanced

No autoboot display

Posted by balanga 
No autoboot display
March 01, 2019 02:15AM
After switching on my GoFlex Home, the U-Boot msg comes up but there is no ' Stop autoboot in x secs' msg so I can't break in.

Is there a variable that sets this?
Re: No autoboot display
March 01, 2019 03:37AM
balanga Wrote:
-------------------------------------------------------
> After switching on my GoFlex Home, the U-Boot msg
> comes up but there is no ' Stop autoboot in x
> secs' msg so I can't break in.
>
> Is there a variable that sets this?

It's the env bootdelay. For example, set it to 10 seconds:

fw_setenv bootdelay 10

Even if it is set to 0, you could still interrupt it if you pound the keyboard before the countdown message comes up.

-bodhi
===========================
Forum Wiki
bodhi's corner



Edited 1 time(s). Last edit at 03/01/2019 03:39AM by bodhi.
Re: No autoboot display
March 01, 2019 06:30AM
After some experimentation using two separate laptops, I see the one with a serial-USB connection displays:-

U-Boot 2017.07-tld-1 (Sep 05 2017 - 00:21:31 -0700)
Seagate GoFlex Home

SoC:   Kirkwood 88F6281_A1
DRAM:  128 MiB
WARNING: Caches not enabled
NAND:  256 MiB
In:    nc
Out:   nc
Err:   nc

but if I start another laptop using 'nc -u -p 6666 192.168.1.21 6666' then it comes up with the

'Hit any key to stop autoboot:' prompt

so I guess that explains what I need to do to access uBoot.
Re: No autoboot display
March 01, 2019 02:40PM
balanga Wrote:
-------------------------------------------------------
> After some experimentation using two separate
> laptops, I see the one with a serial-USB
> connection displays:-
>
>
> U-Boot 2017.07-tld-1 (Sep 05 2017 - 00:21:31
> -0700)
> Seagate GoFlex Home
> 
> SoC:   Kirkwood 88F6281_A1
> DRAM:  128 MiB
> WARNING: Caches not enabled
> NAND:  256 MiB
> In:    nc
> Out:   nc
> Err:   nc
>
>
> but if I start another laptop using 'nc -u -p 6666
> 192.168.1.21 6666' then it comes up with the
>
> 'Hit any key to stop autoboot:' prompt
>
> so I guess that explains what I need to do to
> access uBoot.

Correct. Connect with netconsole.

These envs should be set to serial as default. When u-boot netconsole starts it will set them to nc. But they are nc only during the netconsole running. You must have done a saveenv during netconsole. Because they are nc, you can only access the box with netconsole.

To get back to serial console mode when u-boot starts, login to Debian and set them back to serial.

fw_setenv stderr serial
fw_setenv stdin serial
fw_setenv stdout serial
fw_setenv bootdelay 10

-bodhi
===========================
Forum Wiki
bodhi's corner
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: