Welcome! Log In Create A New Profile

Advanced

GoFlex Home total brick

Posted by Blackbox 
Blackbox
GoFlex Home total brick
October 06, 2012 04:08PM
Hi guys, so i got fully working GoFlex Home - and of course i whanted to flush debian distro - so in process everything whent wrong - after flushing my device gived only red blinking status, after 5 or more rebot/starts - even blinks stoped - so device is not giving any blinking - leds are dead - processor is warming up - on pin 10 connecting gnd i can see some activity when i power on device - at this moment i dont have usb to serial device so i cant do uart uboot fix - i just whant to know if i got the usb to serial cable if it will do any chance to live-up my device - on pins 1 2 3 device dont give anything on console with command "screen /dev/ttyS0 115200" and as i sad cpu is warming up so i think the device IS turning on - and sorry for my english !!! so have i got any chances ?
Blackbox
Re: GoFlex Home total brick
October 06, 2012 04:15PM
kwboot i cant run on my console-system because kwboot is compiled on 64bit system, thats why i need usb to serial - at this moment i have only serial cable with serial port on my old ibm t23 system
Re: GoFlex Home total brick
October 06, 2012 04:24PM
Have you tried to flash back to stock FW?
http://support.goflexhome.hipserv.com/en/reflash/index.html
Blackbox
Re: GoFlex Home total brick
October 06, 2012 04:34PM
@bodhi - already tried - not working - and also i have problem to identify a time to release the reset pin because as i sad - i have no working leds
Blackbox
Re: GoFlex Home total brick
October 07, 2012 01:45PM
tested today - http://forum.doozan.com/read.php?3,7852 - no luck - it stucks on "Sending boot message. Please reboot the target..." cpu is warming up, if HDD drive is mounted its also starting to speed up, no leds, no serial console respond. Any other chance to test if the device is even working ?
Re: GoFlex Home total brick
October 07, 2012 02:50PM
You need a working serial connection to the goflex home.
Post your log please.
Here you can see how i solved it.

http://forum.doozan.com/read.php?3,9760
Blackbox
Re: GoFlex Home total brick
October 07, 2012 05:02PM
@tobi1337 thanks for advice - can i run OpenOCD + USB To RS232 TTL PL2303HX Auto Converter instead of Buspirate ?? Or without any chance i need to buy Buspirate hack-plate ??? I am a bit off the electronic thing, so sorry for my lame questions - what i know is what the word pinout mean and what is linux console
Re: GoFlex Home total brick
October 08, 2012 12:28AM
You Need only a serial connection (TXD, RXD, GND) JTAG doesn't work with the goflex.
Buspirate is for the JTAG. Linux console is the Terminal on Linux ;)
You need Linux to Recover the uboot
Blackbox
Re: GoFlex Home total brick
October 08, 2012 06:43AM
@tobi1337 - so at home i have laptop with com1 port and self-made serial cable - as i understand i only need software(OpenOCD) and can try to do the job as you described in youre post?
Re: GoFlex Home total brick
October 08, 2012 09:49AM
You don´t need OpenOCD. OpenOCD is for JTAG.
Look at my 5. post http://forum.doozan.com/read.php?3,7852

You need an PC with Linux, you must compile the kwboot_Tool read in DavyGravy´s Thread
You also need an TTL Uart with 3V not a Com-Port
Blackbox
Re: GoFlex Home total brick
October 08, 2012 11:37AM
@tobi1337 thanks for youre help, i dont play on youre nervs! I realy appreciate your help!

Link belove is device i bought in ebay - as its says in header -

USB To RS232 TTL PL2303HX Auto Converter Module Converter Adapter 5V 3.3V Output
http://www.ebay.com/itm/350568364250?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649

will this do the job described in links you gave me ?
Re: GoFlex Home total brick
October 08, 2012 02:09PM
yes i have the same interface, works great :)
You also can use a nokia ca-42 orginal / clone cable
Blackbox
Re: GoFlex Home total brick
October 08, 2012 03:40PM
@tobi1337 will look forward to get ca-42 cable maybe faster then ebay package - i will post update when i get one or other cable
Blackbox
Re: GoFlex Home total brick
October 15, 2012 03:28PM
today got my usb adapter but thing is - conecting pc to goflex home and entering in console - ./kwboot -t -B 115200 /dev/ttyUSB0 -b myimage.kwb -p its says after 2sec -

Sending boot image...
0% [+xmodem: Protocol error

and all stops ! any suggestions ?
Blackbox
Re: GoFlex Home total brick
October 16, 2012 11:11AM
so problem in first was with pinouts - its solved - now connecting goflex to pc with PL2303HX - its show activity on pc screen - rounding line - faster then slower again faster but not going to sending image part - PL2303HX is also showing some activity with led blinking - but thats it :(
Re: GoFlex Home total brick
October 28, 2012 11:45AM
Can you copy and paste exactly what you see on your console screen?

=====================================================
Blackbox
Re: GoFlex Home total brick
October 28, 2012 09:53PM
first of all thx for replay, second - can i ask once again for right pinout hols on goflex home - are they 1-2-3 or 10-9-8? third on 1-2-3 or 10-9-8 i got nothing when i connect with command screen /dev/ttyUSB0 115200 - there is no ethernet light and there is no led light - theres only cpu heating up - if i look closly there are red light blinking for sec but its very very low density of light
Tinkerer
Re: GoFlex Home total brick
July 19, 2014 07:53PM
My GoFlexHome is not working :-(

Followed the ArchLinux 16 step install guideline from http://archlinuxarm.org/platforms/armv5/seagate-goflex-home.

After reboot no response. Green LED is blinking. Tried almost all the suggestions from this forum and else where for last four weekends.

No IP, No Ping. No Netconsole. Finally soldered the Serial cable on board. I see garbled characters scrolling in the terminal.

Is my GoFlexHome bricked or can it be recovered?

Please advise how to recover. I would like to install ArchLinux on it.
Re: GoFlex Home total brick
July 19, 2014 09:26PM
Download the GoFlex Home u-boot from this thread:
http://forum.doozan.com/read.php?3,12381

And use serial console to boot with UART method (kwboot) as described in this thread:
http://forum.doozan.com/read.php?3,7852,7852

Stop at the u-boot countdown, plug in your Arch rootfs USB. And boot! Come back here if you have problem booting into Arch or see errors.

-bodhi
===========================
Forum Wiki
bodhi's corner
Tinkrer
Re: GoFlex Home total brick
July 21, 2014 10:21PM
Thanks a lot Bodhi for quick reply.

I tried the suggested method. But as I said earlier I only see garbled characters scrolling on the /dev/ttyUSB0 screen the moment I power up the GoFlex Home.

I did issue following command in another terminal window.

./kwboot -t -B 115200 /dev/ttyUSB0 -b u-boot.kwb

It's waiting with message

Sending boot message. Please reboot the target ... (spinning | character)

Any suggestion?

P.S. I had to rebuild the kwboot as my linux machine is not 64 bit.
Re: GoFlex Home total brick
July 21, 2014 10:33PM
Tinkrer,

Did you download the u-boot I posted? if you did, the command is:

./kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2014.07.tld-1.goflexhome.mtd0.kwb -p

And if you have another ARM plug, then you can use the kwboot binary I uploaded in that same thread.

-bodhi
===========================
Forum Wiki
bodhi's corner
Tinkrer
Re: GoFlex Home total brick
July 21, 2014 11:25PM
Appreciate your quick reply.

Yes. I did try with the binary that you posted.

./kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2014.07.tld-1.goflexhome.mtd0.kwb -p

I do not have another ARM plug.

The | character continues to spin :-(

- Tinkrer
Re: GoFlex Home total brick
July 21, 2014 11:29PM
Tinkrer Wrote:
-------------------------------------------------------
> Appreciate your quick reply.
>
> Yes. I did try with the binary that you posted.
>
> ./kwboot -t -B 115200 /dev/ttyUSB0 -b
> uboot.2014.07.tld-1.goflexhome.mtd0.kwb -p
>
> I do not have another ARM plug.
>
> The | character continues to spin :-(
>
> - Tinkrer

Does the garble characters appear with kwboot command? or just the spinning | ?

-bodhi
===========================
Forum Wiki
bodhi's corner
Tinkrer
Re: GoFlex Home total brick
July 21, 2014 11:40PM
I have two terminal windows open.

In terminal 1
kwboot shows spinning.

In terminal 2
screen /dev/ttyUSB0 115200 shows garbled characters.
Re: GoFlex Home total brick
July 21, 2014 11:55PM
Tinkrer Wrote:
-------------------------------------------------------
> I have two terminal windows open.
>
> In terminal 1
> kwboot shows spinning.
>
> In terminal 2
> screen /dev/ttyUSB0 115200 shows garbled
> characters.

I would check Tx and Rx lines to see they were reversed. Because kwboot handshakes with Boot ROM only, u-boot is not involved. And it's rare that a Goflex Home does not have correct boot ROM for UART.

-bodhi
===========================
Forum Wiki
bodhi's corner
Tinkerer
Re: GoFlex Home total brick
July 22, 2014 12:12AM
I believe that lines are correct. When I reverse the Tx and Rx lines I do not see anything on screen.

This is how the wiring is. Please let me know if this needs correction.

GoFlex Board - Pin 1 -> 9-pin Serial Connector Pin 5 - GND
GoFlex Board - Pin 2 -> 9-pin Serial Connector Pin 2
GoFlex Board - Pin 3 -> 9-pin Serial Connector Pin 3

I'm using USB to 9 pin Serial Connector module. This is the part number.

http://www.hobbyengineering.com/H3284.html

Thanks for your continued help.
Re: GoFlex Home total brick
July 22, 2014 01:49AM
Tinkerer,

I'm looking at the GoFlex Home board picture, inside from the battery looking outward. There are 2 rows of 5 pins.

The top row left most 3 pins are:
GND TX RX

Is that how you determine the pins?

-bodhi
===========================
Forum Wiki
bodhi's corner
Tinkerer
Re: GoFlex Home total brick
July 22, 2014 02:04AM
Yes.

Top row - 3 left most pins.

- Tinkerer
Re: GoFlex Home total brick
July 22, 2014 02:27AM
OK. It might be that your GoFlex Home has the earlier Boot ROM, therefore UART booting does not work.

However, because if u-boot is all messed up, we can't see the Boot ROM to tell for sure. So you might as well try this:

- Start kwboot on the other Linux box:
./kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2014.07.tld-1.goflexhome.mtd0.kwb -p

- Power up the GoFlex Home
- Watch the spinning | . Observe if it slows down or changes direction at all. If it does, then the handshake has occured.
- Within 1-2 seconds (but not too soon), Control-C to abort kwboot, and recall the command, execute kwboot again. If you see the "Bad Message" response then it is a very good sign. If not, it is likely this GoFlex Home has the earlier Boot ROM, and UART does not work.

- Repeatedly run kwboot this way for as long as you can.
- Hope it will handshake successfully.

-bodhi
===========================
Forum Wiki
bodhi's corner
Tinkerer
Re: GoFlex Home total brick
July 22, 2014 10:37AM
Hi bodhi,

Here is what I see:

- Start kwboot on the other Linux box:
./kwboot -t -B 115200 /dev/ttyUSB0 -b uboot.2014.07.tld-1.goflexhome.mtd0.kwb -p

Spinning is relatively slower

- Power up the GoFlex Home

Spinning becomes faster

- Control-C to abort kwboot, and recall the command, execute kwboot again. (GoFlex was powered up)

Spinning starts faster And no "Bad Message" response.

-Tinkerer
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: