Welcome! Log In Create A New Profile


nas iomega ix4-200d bloqueado

Posted by vantdron 
nas iomega ix4-200d bloqueado
May 26, 2021 03:11PM
hola soy usuario no experto y tengo un problema con nas bloqueado iomega ix4-200d. Al principio estaba en loop pero ahora enciende solo la pantalla azul sin letras. Queria ponerle la version de firmware cloud descargada de la pagina oficial de lenovo. He intentado conectar con cable usb ttl 2102, 2303hx y ch3406 utilizando putty, pero no consigo conectarme al nand flash. No se si tengo los cables usb ttl adecuados o ni siquiera si utilizo el programa adecuado. Soy usuario de windows. Por favor, podria indicarme como poder resucitar el nas iomega? Le agradeceria mucho su inestimable ayuda. Muchas gracias.

Google Translate
Hi, I'm a non-expert user and I have a problem with iomega ix4-200d blocked nas. At first it was in loop but now it turns on only the blue screen without letters. I wanted to put the cloud firmware version downloaded from the official Lenovo website. I have tried to connect with usb cable ttl 2102, 2303hx and ch3406 using putty, but I can't connect to nand flash. I don't know if I have the right usb ttl cables or even if I use the right program. I am a windows user. Please, could you tell me how to resurrect the nas iomega? I would greatly appreciate your invaluable help. Thank you.

moderator edit: please translate your post to English before posting.

Edited 1 time(s). Last edit at 05/26/2021 04:27PM by bodhi.
open | download - pinout.jpg (164.3 KB)
Re: nas iomega ix4-200d bloqueado
May 26, 2021 04:43PM

We don't deal with stock FW here, so not much help.

However, I can help with the serial connection and see what is the problem.

If you use Windows putty it will be only a serial connection (with a Linux box connection, we can use UART booting to recover when the FW boot loader is badly messed up).

So look at the ix4-200d serial connection pic here by damacc:


And check the 1st post of that thread:


And mak sure you are using the standard serial protocols settings for serial console. This is how I run serial console from a Linux box:

picocom --b 115200 --f n --p n --d 8 /dev/ttyUSB0

picocom --help

picocom v3.1

Compiled-in options:
TTY_Q_SZ is 0
HIGH_BAUD is enabled
USE_FLOCK is enabled
LINENOISE is enabled
HISTFILE is: .picocom_history
USE_CUSTOM_BAUD is enabled

Usage is: picocom [options] <tty port device>
Options are:
--<b>aud <baudrate>
--<f>low x (=soft,xon/xoff) | h (=hard) | n (=none)
--parit<y> o (=odd) | e (=even) | n (=none)
--<d>atabits 5 | 6 | 7 | 8
--sto<p>bits 1 | 2
--<e>scape <char>
--<s>end-cmd <command>
--recei<v>e-cmd <command>
--imap <map> (input mappings)
--omap <map> (output mappings)
--emap <map> (local-echo mappings)
--lo<g>file <filename>
--inits<t>ring <string>
--e<x>it-after <msec>
<map> is a comma-separated list of one or more of:
crlf : map CR --> LF
crcrlf : map CR --> CR + LF
igncr : ignore CR
lfcr : map LF --> CR
lfcrlf : map LF --> CR + LF
ignlf : ignore LF
bsdel : map BS --> DEL
delbs : map DEL --> BS
spchex : map special chars (excl. CR, LF & TAB) --> hex
tabhex : map TAB --> hex
crhex : map CR --> hex
lfhex : map LF --> hex
8bithex : map 8-bit chars --> hex
nrmhex : map normal ascii chars --> hex
<?> indicates the equivalent short option.
Short options are prefixed by "-" instead of by "--".

Forum Wiki
bodhi's corner (buy bodhi a beer)
Re: nas iomega ix4-200d bloqueado
June 04, 2021 12:44AM
hello please, is there someone who can explain to me for fools how to connect the ix4-200d by the serial port with the usb-ttl? what pins are they? what program to use? can you use the usb-ttl 2102 cable?. If you have any better video. Thanks , I try to recover the iomega ix4-200d nas equipment. are there any video to follows the step? Thank you
Re: nas iomega ix4-200d bloqueado
June 04, 2021 10:25PM

We don't have any video for this. But we have picture of the board where the serial console header is. And the pinout marking for TX, RX and GND.

See my post right above, and then ask question about which part you don't understand.

Forum Wiki
bodhi's corner (buy bodhi a beer)
Re: nas iomega ix4-200d bloqueado
June 07, 2021 02:57PM
the connection looks like this, you have to solder on 3 pins. mine is absolutely not professional, but i had nothing else by hand :)

and then connect with
picocom -b 115200 /dev/ttyUSB1

Edited 1 time(s). Last edit at 06/07/2021 03:00PM by damsma.
open | download - IMG_5212.jpg (143.1 KB)
open | download - IMG_5208.jpg (107.3 KB)

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.