Welcome! Log In Create A New Profile


GoFlex Home uboot update/mac address problem

Posted by trigati 
GoFlex Home uboot update/mac address problem
October 28, 2012 08:36AM
hi guys,

quick question for you, ive a goflex home that has appeared to loose its abilities to acquire a mac address after a uboot update (latest version) , is it time to make myself a serial cable or is it boned?

uboot settings all matched the previous version, all was fine until i rebooted the drive, then its nothing but a series of flashing orange, followed by a few seconds of flashing green, then back to orange. ( i think its flashing orange thats the network from memory i maybe mistaken )
Re: GoFlex Home uboot update/mac address problem
October 28, 2012 11:42AM
Did you have netconsole activated before?

Do you have netconsole working now?

Re: GoFlex Home uboot update/mac address problem
October 28, 2012 12:49PM
yeap it was active, but as i cannot connect via any normal means i cannot determine if its still active.

the device seems to go into its loop before anything useful boots, while plugged directly into my laptop it triggers the laptops network detection for the few seconds its flashing green.
Re: GoFlex Home uboot update/mac address problem
October 28, 2012 03:03PM
The GoFlex units are hard to completely bork/brick/bone. Hard, but not impossible, I guess.

That being said, I've never bricked one - I've always been able to recover by JTAG or easier yet, by kwboot tool.

Yes, now is the time to get a tried and true serial cable and hook it up. I don't know where the pinout diagram is, nor do I know where the links for the best serial connectors... I use an FTDI unit, RS232 IIRC.

Once you have serial connectivity, you'll be able to troubleshoot it more easily, most likely.


Is it possible to get a serial connection the other way, with the usb port on the plug and the serial side attached to a real com port on the computer? I have a very very old laptop (no usb) that I would like to use as a terminal for my plugs.

Re: GoFlex Home uboot update/mac address problem
January 11, 2013 02:50AM
Hi trigati,

you probably solved your problems already, but I had a similar problem yesterday. I updated uBoot on the GoFlex Home and after that it did not boot into the pogoplug anymore. I did try to set some environment variables right after I had done the update, but fw_setenv/fw_printenv was not recognized ...

Then, I tried to boot debian from Sticks I have (which work on both Dockstar and GoFlex Net) and it did boot, but gave me random IP-addresses after each boot due to that fact that it also randomly set the MAC-address (which I was able to check using my router's web interface). Now the problem with this was, that the debian would not let me ssh to the GoFlex Home ... So I tried to set a static ip (by editing the file /etc/network/interfaces on the stick), but that did not help either.

What did help was to use ALARM, since that would let me ssh! I then had to reinstall uBoot, since that also installs fw_setenv/fw_printenv in the ALARM system. I was then able to change the uBoot environment, giving it a fixed MAC address and so on and finally also install the rescue system. So, what I am asking myself is whether, when doing the uBoot update for the first time, one should remount the system in rw-mode, since then fw_setenv/fw_printenv should get installed (into /usr/sbin ...) right away and it should be possible to set the environment variables right after the update, I think. Of course, now it is too late to test.

Now, my only problem is that the GFH does not see the 3TB SATA, although it is audibly running. But I hope I will be able to fix that with one of the numerous posts in this forum ...



Standart ist der Standardfehler
Re: GoFlex Home uboot update/mac address problem
January 11, 2013 09:13PM
If your disk is running, but not seen, I sould start with confirming your arcNumber value, then look at causing your sata bus to rescan.

echo "0 0 0" > /sys/class/scsi_host/host0/scan
Re: GoFlex Home uboot update/mac address problem
February 27, 2013 02:23PM
If you are trying to boot from the 3TB, a hybrid MBR is a necessity. Works fine once you get it configured.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.